You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-scroll_derive/rust-scroll_derive.spec

71 lines
1.5 KiB

# Generated by rust2rpm 24
# * resolve dependency loop with scroll
%bcond_with check
%global debug_package %{nil}
%global crate scroll_derive
Name: rust-scroll_derive
Version: 0.11.1
Release: %autorelease
Summary: Derive implementation for scroll::Pread and scroll::Pwrite traits
License: MIT
URL: https://crates.io/crates/scroll_derive
Source: %{crates_source}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
A macros 1.1 derive implementation for Pread and Pwrite traits from the
scroll crate.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog