You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
113 lines
2.7 KiB
113 lines
2.7 KiB
# Generated by rust2rpm 21
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate scroll
|
|
|
|
Name: rust-%{crate}
|
|
Version: 0.11.0
|
|
Release: %autorelease
|
|
Summary: Powerful, extensible, generic, endian-aware Read/Write traits for byte buffers
|
|
|
|
# Upstream license specification: MIT
|
|
License: MIT
|
|
URL: https://crates.io/crates/scroll
|
|
Source: %{crates_source}
|
|
|
|
ExclusiveArch: %{rust_arches}
|
|
|
|
BuildRequires: rust-packaging >= 21
|
|
|
|
%global _description %{expand:
|
|
Suite of powerful, extensible, generic, endian-aware Read/Write traits for byte
|
|
buffers.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE
|
|
%doc %{crate_instdir}/CHANGELOG.md
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+derive-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+derive-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "derive" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+derive-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+scroll_derive-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+scroll_derive-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "scroll_derive" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+scroll_derive-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+std-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+std-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "std" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+std-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires -a
|
|
|
|
%build
|
|
%cargo_build -a
|
|
|
|
%install
|
|
%cargo_install -a
|
|
|
|
%if %{with check}
|
|
%check
|
|
# * readme doctests fail to compile
|
|
# * one doc test is broken on s390x / big-endian
|
|
# https://github.com/m4b/scroll/issues/77
|
|
%cargo_test -a -- --lib
|
|
%endif
|
|
|
|
%changelog
|
|
%autochangelog
|