You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-scc/rust-scc.spec

99 lines
2.3 KiB

# Generated by rust2rpm 27
%bcond check 1
%global debug_package %{nil}
%global crate scc
Name: rust-scc
Version: 2.2.5
Release: %autorelease
Summary: Containers and utilities for concurrent and asynchronous programming
License: Apache-2.0
URL: https://crates.io/crates/scc
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency
# * drop features for perturbation testing with loom
Patch: scc-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
High performance containers and utilities for concurrent and
asynchronous programming.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+equivalent-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+equivalent-devel %{_description}
This package contains library source intended for building other packages which
use the "equivalent" feature of the "%{crate}" crate.
%files -n %{name}+equivalent-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog