Release 0.2.1

Signed-off-by: Robert-André Mauchin <zebob.m@gmail.com>
epel9
Robert-André Mauchin 6 years ago
parent 5d61f4c6bf
commit 4c5e7462dd

@ -5,21 +5,18 @@
%global crate scan_fmt
Name: rust-%{crate}
Version: 0.1.3
Release: 2%{?dist}
Version: 0.2.1
Release: 1%{?dist}
Summary: Simple scanf()-like input for Rust
License: MIT
URL: https://crates.io/crates/scan_fmt
Source: %{crates_source}
# Initial patched metadata
# - Bump regex to 1.0.0 https://github.com/wlentz/scan_fmt/pull/6
Patch0: scan_fmt-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: (crate(regex/default) >= 1.0.0 with crate(regex/default) < 2.0.0)
BuildRequires: (crate(regex/default) >= 1.1.6 with crate(regex/default) < 1.2.0)
%global _description \
A simple scanf()-like input for Rust.
@ -52,6 +49,18 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+regex-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+regex-devel %{_description}
This package contains library source intended for building other packages
which use "regex" feature of "%{crate}" crate.
%files -n %{name}+regex-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
@ -68,6 +77,9 @@ which use "default" feature of "%{crate}" crate.
%endif
%changelog
* Sat May 04 16:31:35 CEST 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.2.1-1
- Release 0.2.1
* Wed Mar 20 09:54:38 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.3-2
- Run tests in infrastructure

@ -1,8 +0,0 @@
--- scan_fmt-0.1.3/Cargo.toml 1970-01-01T01:00:00+01:00
+++ scan_fmt-0.1.3/Cargo.toml 2019-03-16T18:36:46.105290+01:00
@@ -23,4 +23,4 @@
name = "scan_fmt"
path = "src/lib.rs"
[dependencies.regex]
-version = "0.2.6"
+version = "1.0.0"
Loading…
Cancel
Save