commit
8ba2a5a6b0
Binary file not shown.
@ -0,0 +1,28 @@
|
||||
--- rxml-0.9.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ rxml-0.9.1/Cargo.toml 2023-08-31T19:40:04.618218+00:00
|
||||
@@ -29,14 +29,6 @@
|
||||
[package.metadata.docs.rs]
|
||||
all-features = true
|
||||
|
||||
-[[bench]]
|
||||
-name = "parse"
|
||||
-harness = false
|
||||
-
|
||||
-[[bench]]
|
||||
-name = "q"
|
||||
-harness = false
|
||||
-
|
||||
[dependencies.bytes]
|
||||
version = "^1"
|
||||
|
||||
@@ -67,10 +59,6 @@
|
||||
version = "^0.3"
|
||||
optional = true
|
||||
|
||||
-[dev-dependencies.criterion]
|
||||
-version = "^0.3"
|
||||
-features = ["html_reports"]
|
||||
-
|
||||
[dev-dependencies.tokio]
|
||||
version = "^1"
|
||||
features = [
|
@ -0,0 +1,215 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate rxml
|
||||
|
||||
Name: rust-rxml
|
||||
Version: 0.9.1
|
||||
Release: %autorelease
|
||||
Summary: Minimalistic, restricted XML 1.0 parser which does not include dangerous XML features
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/rxml
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
|
||||
Patch: rxml-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Minimalistic, restricted XML 1.0 parser which does not include dangerous
|
||||
XML features.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/COPYING
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+async-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+async-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "async" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+async-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+futures-core-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+futures-core-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "futures-core" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+futures-core-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+macros-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+macros-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "macros" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+macros-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+mt-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+mt-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "mt" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+mt-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+pin-project-lite-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+pin-project-lite-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "pin-project-lite" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+pin-project-lite-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rxml_proc-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rxml_proc-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rxml_proc" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rxml_proc-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+shared_ns-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+shared_ns-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "shared_ns" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+shared_ns-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+stream-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+stream-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "stream" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+stream-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tokio-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tokio-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tokio" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tokio-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+weak-table-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+weak-table-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "weak-table" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+weak-table-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.9.1-1
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Thu Aug 31 2023 Fabio Valentini <decathorpe@gmail.com> - 0.9.1-1
|
||||
- Update to version 0.9.1; Fixes RHBZ#2164389
|
||||
|
||||
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Tue Dec 27 2022 Michel Alexandre Salim <salimma@fedoraproject.org> - 0.8.2-1
|
||||
- Initial Fedora package
|
Loading…
Reference in new issue