You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-ruzstd/rust-ruzstd.spec

87 lines
2.0 KiB

# Generated by rust2rpm 25
# * data files required by tests are not included in published crates
%bcond_with check
%global debug_package %{nil}
%global crate ruzstd
Name: rust-ruzstd
Version: 0.5.0
Release: %autorelease
Summary: Decoder for the zstd compression format
License: MIT
URL: https://crates.io/crates/ruzstd
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop unused command-line applications
# * drop unused, benchmark-only criterion dev-dependency
Patch: ruzstd-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A decoder for the zstd compression format.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/Readme.md
%doc %{crate_instdir}/optimizations.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog