parent
eee98d1cb8
commit
da6309f0b4
@ -0,0 +1 @@
|
||||
/ruzstd-0.5.0.crate
|
@ -0,0 +1,86 @@
|
||||
# Generated by rust2rpm 25
|
||||
# * data files required by tests are not included in published crates
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate ruzstd
|
||||
|
||||
Name: rust-ruzstd
|
||||
Version: 0.5.0
|
||||
Release: %autorelease
|
||||
Summary: Decoder for the zstd compression format
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/ruzstd
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop unused command-line applications
|
||||
# * drop unused, benchmark-only criterion dev-dependency
|
||||
Patch: ruzstd-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
A decoder for the zstd compression format.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/Readme.md
|
||||
%doc %{crate_instdir}/optimizations.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "std" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1,32 @@
|
||||
--- ruzstd-0.5.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ ruzstd-0.5.0/Cargo.toml 2023-11-29T18:54:43.112157+00:00
|
||||
@@ -24,18 +24,7 @@
|
||||
readme = "Readme.md"
|
||||
license = "MIT"
|
||||
repository = "https://github.com/KillingSpark/zstd-rs"
|
||||
-
|
||||
-[[bin]]
|
||||
-name = "zstd"
|
||||
-required-features = ["std"]
|
||||
-
|
||||
-[[bin]]
|
||||
-name = "zstd_stream"
|
||||
-required-features = ["std"]
|
||||
-
|
||||
-[[bench]]
|
||||
-name = "reversedbitreader_bench"
|
||||
-harness = false
|
||||
+autobins = false
|
||||
|
||||
[dependencies.byteorder]
|
||||
version = "1.5"
|
||||
@@ -53,9 +42,6 @@
|
||||
version = "1.6"
|
||||
default-features = false
|
||||
|
||||
-[dev-dependencies.criterion]
|
||||
-version = "0.3"
|
||||
-
|
||||
[dev-dependencies.rand]
|
||||
version = "0.8.5"
|
||||
features = ["small_rng"]
|
Loading…
Reference in new issue