Update to version 0.7.2; Fixes RHBZ#2307081

epel10
Fabio Valentini 4 months ago
parent 0ffb9ecd4c
commit 2853bbe6ae
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -1,2 +1,3 @@
/ruzstd-0.5.0.crate
/ruzstd-0.7.0.crate
/ruzstd-0.7.2.crate

@ -1,5 +1,6 @@
# Generated by rust2rpm 26
%bcond_without check
# * test fixtures are not included in published crates
%bcond_with check
%global debug_package %{nil}
# prevent executables from being installed
@ -8,16 +9,13 @@
%global crate ruzstd
Name: rust-ruzstd
Version: 0.7.0
Version: 0.7.2
Release: %autorelease
Summary: Decoder for the zstd compression format
License: MIT
URL: https://crates.io/crates/ruzstd
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency
Patch: ruzstd-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 26
@ -93,8 +91,7 @@ use the "std" feature of the "%{crate}" crate.
%if %{with check}
%check
# * test fixtures not shipped
%cargo_test -- -- --exact --skip tests::decode_corpus::test_decode_corpus_files --skip tests::dict_test::test_dict_decoding --skip tests::fuzz_regressions::test_all_artifacts --skip tests::test_block_header_reading --skip tests::test_decode_from_to --skip tests::test_frame_decoder --skip tests::test_frame_header_reading --skip tests::test_specific_file --skip tests::test_streaming
%cargo_test
%endif
%changelog

@ -1,19 +1,12 @@
[package]
cargo-install-bin = false
[tests]
skip = [
"tests::decode_corpus::test_decode_corpus_files",
"tests::dict_test::test_dict_decoding",
"tests::fuzz_regressions::test_all_artifacts",
"tests::test_block_header_reading",
"tests::test_decode_from_to",
"tests::test_frame_decoder",
"tests::test_frame_header_reading",
"tests::test_specific_file",
"tests::test_streaming",
]
skip-exact = true
comments = [
"test fixtures not shipped",
[features]
hide = [
"rustc-dep-of-std",
]
[tests]
run = ["none"]
comments = ["test fixtures are not included in published crates"]

@ -1,23 +0,0 @@
--- ruzstd-0.7.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ ruzstd-0.7.0/Cargo.toml 2024-07-23T18:53:00.176423+00:00
@@ -39,10 +39,6 @@
name = "zstd_stream"
required-features = ["std"]
-[[bench]]
-name = "reversedbitreader_bench"
-harness = false
-
[dependencies.byteorder]
version = "1.5"
default-features = false
@@ -51,9 +47,6 @@
version = "1.6"
optional = true
default-features = false
-
-[dev-dependencies.criterion]
-version = "0.5"
[dev-dependencies.rand]
version = "0.8.5"

@ -1 +1 @@
SHA512 (ruzstd-0.7.0.crate) = 06e1a584fb9abf214b9924391f305ce99c7d0278e6aadb99fe62f48746a7974daab74e8c324c9fa6170e3a4ad6ed4e967a458b6ec77c3dc044082edca2ea4fef
SHA512 (ruzstd-0.7.2.crate) = a129deb9496cafe7429edef3d22d90510a67a0ab8e89011c4c9e38b7ffa76dd3f885cf70ad40179cf2165cc7f1f97234f1795e37f4c6aceb438fe5bbe3aeee8c

Loading…
Cancel
Save