You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
167 lines
5.3 KiB
167 lines
5.3 KiB
## START: Set by rpmautospec
|
|
## (rpmautospec version 0.7.3)
|
|
## RPMAUTOSPEC: autorelease, autochangelog
|
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
|
release_number = 1;
|
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
|
print(release_number + base_release_number - 1);
|
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
|
## END: Set by rpmautospec
|
|
|
|
# Generated by rust2rpm 27
|
|
%bcond check 1
|
|
%global debug_package %{nil}
|
|
|
|
%global crate rustversion
|
|
|
|
Name: rust-rustversion
|
|
Version: 1.0.19
|
|
Release: %autorelease
|
|
Summary: Conditional compilation according to rustc compiler version
|
|
|
|
License: MIT OR Apache-2.0
|
|
URL: https://crates.io/crates/rustversion
|
|
Source: %{crates_source}
|
|
|
|
BuildRequires: cargo-rpm-macros >= 24
|
|
|
|
%global _description %{expand:
|
|
Conditional compilation according to rustc compiler version.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE-APACHE
|
|
%license %{crate_instdir}/LICENSE-MIT
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
## START: Generated by rpmautospec
|
|
* Fri Jan 03 2025 Fabio Valentini <decathorpe@gmail.com> - 1.0.19-1
|
|
- Update to version 1.0.19; Fixes RHBZ#2334268
|
|
|
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 1.0.18-1
|
|
- Rebuilt for MSVSphere 10
|
|
|
|
* Sun Oct 20 2024 Fabio Valentini <decathorpe@gmail.com> - 1.0.18-1
|
|
- Update to version 1.0.18; Fixes RHBZ#2318620
|
|
|
|
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.16-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
|
|
|
* Tue May 07 2024 Fabio Valentini <decathorpe@gmail.com> - 1.0.16-1
|
|
- Update to version 1.0.16; Fixes RHBZ#2279450
|
|
|
|
* Tue Apr 16 2024 Fabio Valentini <decathorpe@gmail.com> - 1.0.15-1
|
|
- Update to version 1.0.15; Fixes RHBZ#2273797
|
|
|
|
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.14-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
|
|
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.14-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
|
|
|
* Mon Jul 17 2023 Fabio Valentini <decathorpe@gmail.com> - 1.0.14-1
|
|
- Update to version 1.0.14; Fixes RHBZ#2223136
|
|
|
|
* Wed Jul 05 2023 Fabio Valentini <decathorpe@gmail.com> - 1.0.13-1
|
|
- Update to version 1.0.13; Fixes RHBZ#2219477
|
|
|
|
* Mon Mar 06 2023 Fabio Valentini <decathorpe@gmail.com> - 1.0.12-1
|
|
- Update to version 1.0.12; Fixes RHBZ#2175573
|
|
|
|
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.11-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
|
|
|
* Tue Dec 20 2022 Fabio Valentini <decathorpe@gmail.com> - 1.0.11-1
|
|
- Update to version 1.0.11; Fixes RHBZ#2154593
|
|
|
|
* Sat Aug 06 2022 Fabio Valentini <decathorpe@gmail.com> - 1.0.9-1
|
|
- Update to version 1.0.9; Fixes RHBZ#2107773
|
|
|
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.7-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
|
|
|
* Fri Jul 15 2022 Fabio Valentini <decathorpe@gmail.com> - 1.0.7-1
|
|
- Update to version 1.0.7; Fixes RHBZ#2098491
|
|
|
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.6-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
|
|
|
* Thu Dec 09 2021 Fabio Valentini <decathorpe@gmail.com> - 1.0.6-1
|
|
- Update to version 1.0.6; Fixes RHBZ#2029282
|
|
|
|
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.5-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
|
|
|
* Sun May 16 2021 Fabio Valentini <decathorpe@gmail.com> - 1.0.5-1
|
|
- Update to version 1.0.5.
|
|
- Fixes RHBZ#1960790
|
|
|
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.4-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
|
|
|
* Thu Nov 12 2020 Fabio Valentini <decathorpe@gmail.com> - 1.0.4-1
|
|
- Update to version 1.0.4.
|
|
- Fixes RHBZ#1891615
|
|
|
|
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.3-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
|
|
|
* Fri Jun 19 2020 Josh Stone <jistone@redhat.com> - 1.0.3-1
|
|
- Update to 1.0.3
|
|
|
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.2-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
|
|
|
* Mon Jan 27 2020 Josh Stone <jistone@redhat.com> - 1.0.2-1
|
|
- Update to 1.0.2
|
|
|
|
* Tue Jan 07 2020 Josh Stone <jistone@redhat.com> - 1.0.1-1
|
|
- Update to 1.0.1
|
|
|
|
* Sat Dec 14 09:30:25 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.0.0-1
|
|
- Initial package
|
|
|
|
## END: Generated by rpmautospec
|