Initial import (#2214364)
parent
c3e17d3d92
commit
93a09239de
@ -0,0 +1 @@
|
||||
/rustls-webpki-0.100.1.crate
|
@ -0,0 +1,113 @@
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate rustls-webpki
|
||||
|
||||
# compile and run tests only on supported architectures
|
||||
%global supported_arches x86_64 %{ix86} aarch64 %{arm}
|
||||
|
||||
Name: rust-rustls-webpki
|
||||
Version: 0.100.1
|
||||
Release: %autorelease
|
||||
Summary: Web PKI X.509 Certificate Verification
|
||||
|
||||
# Upstream license specification: None
|
||||
# * rustls-webpki itself is licensed under the terms of the ISC license
|
||||
# * third-party data from chromium is licensed under a 3-Clause-BSD license,
|
||||
# but it is only used for integration tests and not included in RPM packages
|
||||
License: ISC
|
||||
URL: https://crates.io/crates/rustls-webpki
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * specify license with SPDX identifier in crate metadata:
|
||||
# https://github.com/rustls/webpki/issues/101
|
||||
# https://github.com/rustls/webpki/pull/102
|
||||
Patch: rustls-webpki-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Web PKI X.509 Certificate Verification.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
# exclude integration tests and associated data from installed files
|
||||
%exclude %{crate_instdir}/tests/
|
||||
%exclude %{crate_instdir}/third-party/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+alloc-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+alloc-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "alloc" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+alloc-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "std" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
# drop tests which require files that are not included in published crates
|
||||
rm tests/integration.rs
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%ifarch %{supported_arches}
|
||||
%cargo_build
|
||||
%endif
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%ifarch %{supported_arches}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1,6 @@
|
||||
[DEFAULT]
|
||||
supported-arches =
|
||||
x86_64
|
||||
%{ix86}
|
||||
aarch64
|
||||
%{arm}
|
@ -0,0 +1,11 @@
|
||||
--- rustls-webpki-0.100.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ rustls-webpki-0.100.1/Cargo.toml 2023-06-12T18:22:12.900252+00:00
|
||||
@@ -55,7 +55,7 @@
|
||||
"cryptography",
|
||||
"no-std",
|
||||
]
|
||||
-license-file = "LICENSE"
|
||||
+license = "ISC"
|
||||
repository = "https://github.com/rustls/webpki"
|
||||
|
||||
[package.metadata.docs.rs]
|
Loading…
Reference in new issue