epel10
imports/epel10/rust-rustls-native-certs0.7-0.7.3-1.el10
parent
bdbbb57f45
commit
30323bfca8
@ -0,0 +1 @@
|
||||
/rustls-native-certs-0.7.3.crate
|
@ -1,3 +0,0 @@
|
||||
# rust-rustls-native-certs0.7
|
||||
|
||||
The rust-rustls-native-certs0.7 package
|
@ -0,0 +1,77 @@
|
||||
# Generated by rust2rpm 26
|
||||
# * missing dev-dependencies: x509-parser ^0.16
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate rustls-native-certs
|
||||
|
||||
Name: rust-rustls-native-certs0.7
|
||||
Version: 0.7.3
|
||||
Release: %autorelease
|
||||
Summary: Allows rustls to use the platform native certificate store
|
||||
|
||||
License: Apache-2.0 OR ISC OR MIT
|
||||
URL: https://crates.io/crates/rustls-native-certs
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip dependencies and normalize metadata
|
||||
Patch: rustls-native-certs-fix-metadata-auto.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Rustls-native-certs allows rustls to use the platform native certificate
|
||||
store.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-ISC
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/CONTRIBUTING.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%doc %{crate_instdir}/RELEASING.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1,4 @@
|
||||
[tests]
|
||||
run = ["none"]
|
||||
comments = ["missing dev-dependencies: x509-parser ^0.16"]
|
||||
|
@ -0,0 +1,11 @@
|
||||
--- rustls-native-certs-0.7.3/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ rustls-native-certs-0.7.3/Cargo.toml 2024-10-08T12:56:33.487433+00:00
|
||||
@@ -83,8 +83,3 @@
|
||||
[target.'cfg(all(unix, not(target_os = "macos")))'.dependencies.openssl-probe]
|
||||
version = "0.1.2"
|
||||
|
||||
-[target.'cfg(target_os = "macos")'.dependencies.security-framework]
|
||||
-version = "2"
|
||||
-
|
||||
-[target."cfg(windows)".dependencies.schannel]
|
||||
-version = "0.1"
|
Loading…
Reference in new issue