You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-rustls-native-certs/rust-rustls-native-certs.spec

85 lines
2.0 KiB

# Generated by rust2rpm 24
# * missing dev-dependency: x509-parser
%bcond_with check
%global debug_package %{nil}
%global crate rustls-native-certs
# compile and run tests only on supported architectures
%global supported_arches x86_64 %{ix86} aarch64 %{arm}
Name: rust-rustls-native-certs
Version: 0.6.3
Release: %autorelease
Summary: Allow rustls to use the platform native certificate store
License: Apache-2.0 OR ISC OR MIT
URL: https://crates.io/crates/rustls-native-certs
Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies
Patch: rustls-native-certs-fix-metadata-auto.diff
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Rustls-native-certs allows rustls to use the platform native certificate
store.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-ISC
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CONTRIBUTING.md
%doc %{crate_instdir}/README.md
%doc %{crate_instdir}/RELEASING.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%ifarch %{supported_arches}
%cargo_build
%endif
%install
%cargo_install
%if %{with check}
%ifarch %{supported_arches}
%check
%cargo_test
%endif
%endif
%changelog
%autochangelog