Update to version 0.6.3; Fixes RHBZ#2215072

epel9 imports/e9/rust-rustls-native-certs-0.6.3-1.el9
Fabio Valentini 2 years ago
parent 7a39eb4531
commit 94a251fded
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -3,3 +3,4 @@
/rustls-native-certs-0.5.0.crate
/rustls-native-certs-0.6.2.crate
/rustls-native-certs-0.6.3.crate

@ -5,21 +5,20 @@
%global crate rustls-native-certs
# compile and run tests only on supported architectures
%global supported_arches x86_64 %{ix86} aarch64 %{arm}
Name: rust-rustls-native-certs
Version: 0.6.2
Version: 0.6.3
Release: %autorelease
Summary: Allow rustls to use the platform native certificate store
# Upstream license specification: Apache-2.0/ISC/MIT
License: Apache-2.0 OR ISC OR MIT
URL: https://crates.io/crates/rustls-native-certs
Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies
Patch: rustls-native-certs-fix-metadata-auto.diff
# ring is not available on ppc64le and s390x
ExcludeArch: ppc64le s390x
BuildRequires: rust-packaging >= 21
%global _description %{expand:
@ -67,15 +66,19 @@ use the "default" feature of the "%{crate}" crate.
%cargo_generate_buildrequires
%build
%ifarch %{supported_arches}
%cargo_build
%endif
%install
%cargo_install
%if %{with check}
%ifarch %{supported_arches}
%check
%cargo_test
%endif
%endif
%changelog
%autochangelog

@ -0,0 +1,6 @@
[DEFAULT]
supported-arches =
x86_64
%{ix86}
aarch64
%{arm}

@ -1,10 +1,11 @@
--- rustls-native-certs-0.6.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ rustls-native-certs-0.6.2/Cargo.toml 2023-03-18T21:28:12.757025+00:00
@@ -44,7 +44,3 @@
version = "0.12"
--- rustls-native-certs-0.6.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ rustls-native-certs-0.6.3/Cargo.toml 2023-07-15T14:12:24.879360+00:00
@@ -51,8 +51,3 @@
[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-probe]
version = "0.1.2"
-[target."cfg(target_os = \"macos\")".dependencies.security-framework]
-version = "2.0.0"
-
-[target."cfg(windows)".dependencies.schannel]
-version = "0.1.15"

@ -1 +1 @@
SHA512 (rustls-native-certs-0.6.2.crate) = 04c7a39cd62d1845c4430ae63fc739ed21e2cb43ec49ff77fb18867b1e8a16c4a03146583a25242c8b44b44090b38b45a550b2852824b975c3466a1740349968
SHA512 (rustls-native-certs-0.6.3.crate) = 53a3a4b96f05dd06c575b2eb62eb7b6d026bda539c87c0e2a4bc84fd332c6401a825135fecdda39c489b0c910ffbe4d42c93844fbdd8da4fc2badad400b27264

Loading…
Cancel
Save