You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
60 lines
1.0 KiB
60 lines
1.0 KiB
--- rustix-0.37.23/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
+++ rustix-0.37.23/Cargo.toml 2023-07-05T19:14:54.852609+00:00
|
|
@@ -68,26 +68,8 @@
|
|
"wasm32-wasi",
|
|
]
|
|
|
|
-[[bench]]
|
|
-name = "mod"
|
|
-harness = false
|
|
-
|
|
-[dependencies.alloc]
|
|
-version = "1.0.0"
|
|
-optional = true
|
|
-package = "rustc-std-workspace-alloc"
|
|
-
|
|
[dependencies.bitflags]
|
|
version = "1.3.2"
|
|
-
|
|
-[dependencies.compiler_builtins]
|
|
-version = "0.1.49"
|
|
-optional = true
|
|
-
|
|
-[dependencies.core]
|
|
-version = "1.0.0"
|
|
-optional = true
|
|
-package = "rustc-std-workspace-core"
|
|
|
|
[dependencies.io-lifetimes]
|
|
version = "1.0.10"
|
|
@@ -127,7 +109,6 @@
|
|
|
|
[build-dependencies.cc]
|
|
version = "1.0.68"
|
|
-optional = true
|
|
|
|
[features]
|
|
all-apis = [
|
|
@@ -149,6 +130,7 @@
|
|
"os_pipe",
|
|
"fs-err",
|
|
]
|
|
+cc = []
|
|
default = [
|
|
"std",
|
|
"use-libc-auxv",
|
|
@@ -177,13 +159,6 @@
|
|
]
|
|
rand = []
|
|
runtime = []
|
|
-rustc-dep-of-std = [
|
|
- "core",
|
|
- "alloc",
|
|
- "compiler_builtins",
|
|
- "linux-raw-sys/rustc-dep-of-std",
|
|
- "bitflags/rustc-dep-of-std",
|
|
-]
|
|
std = ["io-lifetimes"]
|
|
termios = []
|
|
thread = []
|