You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-rustix0.37/rustix-fix-metadata-auto.diff

33 lines
1.2 KiB

--- rustix-0.37.23/Cargo.toml 1970-01-01T00:00:01+00:00
+++ rustix-0.37.23/Cargo.toml 2023-07-05T19:13:57.600367+00:00
@@ -203,9 +203,6 @@
]
default-features = false
-[target."cfg(all(criterion, not(any(target_os = \"emscripten\", target_os = \"wasi\"))))".dev-dependencies.criterion]
-version = "0.4"
-
[target."cfg(all(not(rustix_use_libc), not(miri), target_os = \"linux\", any(target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"), all(target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\")))))".dependencies.libc]
version = "0.2.144"
features = ["extra_traits"]
@@ -240,19 +237,3 @@
version = "1.5.2"
optional = true
-[target."cfg(windows)".dependencies.libc_errno]
-version = "0.3.1"
-default-features = false
-package = "errno"
-
-[target."cfg(windows)".dependencies.windows-sys]
-version = "0.48.0"
-features = [
- "Win32_Foundation",
- "Win32_Networking_WinSock",
- "Win32_NetworkManagement_IpHelper",
- "Win32_System_Threading",
-]
-
-[target."cfg(windows)".dev-dependencies.ctor]
-version = "0.2.0"