You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
423 lines
12 KiB
423 lines
12 KiB
# Generated by rust2rpm 25
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate rustix
|
|
|
|
Name: rust-rustix0.37
|
|
Version: 0.37.26
|
|
Release: %autorelease
|
|
Summary: Safe Rust bindings to POSIX/Unix/Linux/Winsock2-like syscalls
|
|
|
|
License: Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
|
|
URL: https://crates.io/crates/rustix
|
|
Source: %{crates_source}
|
|
# Automatically generated patch to strip dependencies and normalize metadata
|
|
Patch: rustix-fix-metadata-auto.diff
|
|
# Manually created patch for downstream crate metadata changes
|
|
# * drop dependencies on compiler internals
|
|
# * make cc build-dependency non-optional
|
|
Patch: rustix-fix-metadata.diff
|
|
# * unconditionally rebuild static objects from Assembly
|
|
Patch: 0001-Unconditionally-compile-C-Assembly-code-from-source.patch
|
|
|
|
BuildRequires: cargo-rpm-macros >= 24
|
|
|
|
%global _description %{expand:
|
|
Safe Rust bindings to POSIX/Unix/Linux/Winsock2-like syscalls.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/COPYRIGHT
|
|
%license %{crate_instdir}/LICENSE-APACHE
|
|
%license %{crate_instdir}/LICENSE-Apache-2.0_WITH_LLVM-exception
|
|
%license %{crate_instdir}/LICENSE-MIT
|
|
%doc %{crate_instdir}/CODE_OF_CONDUCT.md
|
|
%doc %{crate_instdir}/CONTRIBUTING.md
|
|
%doc %{crate_instdir}/ORG_CODE_OF_CONDUCT.md
|
|
%doc %{crate_instdir}/README.md
|
|
%doc %{crate_instdir}/SECURITY.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+all-apis-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+all-apis-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "all-apis" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+all-apis-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+all-impls-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+all-impls-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "all-impls" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+all-impls-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+cc-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+cc-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "cc" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+cc-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+fs-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+fs-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "fs" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+fs-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+fs-err-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+fs-err-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "fs-err" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+fs-err-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+io-lifetimes-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+io-lifetimes-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "io-lifetimes" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+io-lifetimes-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+io_uring-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+io_uring-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "io_uring" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+io_uring-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+itoa-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+itoa-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "itoa" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+itoa-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+libc-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+libc-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "libc" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+libc-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+libc_errno-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+libc_errno-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "libc_errno" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+libc_errno-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+linux_4_11-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+linux_4_11-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "linux_4_11" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+linux_4_11-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+linux_latest-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+linux_latest-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "linux_latest" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+linux_latest-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+mm-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+mm-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "mm" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+mm-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+net-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+net-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "net" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+net-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+once_cell-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+once_cell-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "once_cell" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+once_cell-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+os_pipe-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+os_pipe-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "os_pipe" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+os_pipe-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+param-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+param-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "param" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+param-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+process-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+process-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "process" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+process-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+procfs-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+procfs-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "procfs" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+procfs-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+pty-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+pty-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "pty" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+pty-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+rand-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+rand-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "rand" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+rand-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+runtime-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+runtime-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "runtime" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+runtime-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+std-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+std-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "std" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+std-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+termios-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+termios-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "termios" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+termios-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+thread-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+thread-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "thread" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+thread-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+time-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+time-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "time" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+time-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+use-libc-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+use-libc-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "use-libc" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+use-libc-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+use-libc-auxv-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+use-libc-auxv-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "use-libc-auxv" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+use-libc-auxv-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version} -p1
|
|
%cargo_prep
|
|
# Remove pre-built binaries
|
|
rm -r src/backend/linux_raw/arch/outline/debug/
|
|
rm -r src/backend/linux_raw/arch/outline/release/
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
%autochangelog
|