Regenerate with rust2rpm v24

epel9
Fabio Valentini 2 years ago
parent a14b7390cb
commit d4b215fa04
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,3 +0,0 @@
# rust-rustc-serialize
The rust-rustc-serialize package

@ -1,51 +1,47 @@
# Generated by rust2rpm
# * Tests are run in infrastructure
# Generated by rust2rpm 24
# * tests no longer compile with recent versions of Rust
%bcond_with check
%global debug_package %{nil}
%global crate rustc-serialize
Name: rust-%{crate}
Name: rust-rustc-serialize
Version: 0.3.24
Release: %autorelease
Summary: Generic serialization/deserialization support
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
License: MIT OR Apache-2.0
URL: https://crates.io/crates/rustc-serialize
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Bump rand to 0.4
# * Exclude CI files
Patch0: rustc-serialize-fix-metadata.diff
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * exclude CI configuration files
Patch: rustc-serialize-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging >= 21
BuildRequires: rust-packaging
%if %{with check}
BuildRequires: (crate(rand/default) >= 0.4.0 with crate(rand/default) < 0.5.0)
%endif
%global _description \
Generic serialization/deserialization support corresponding to the\
`derive(RustcEncodable, RustcDecodable)` mode in the compiler. Also includes\
support for hex, base64, and json encoding and decoding.
%global _description %{expand:
Generic serialization/deserialization support corresponding to the
`derive(RustcEncodable, RustcDecodable)` mode in the compiler. Also
includes support for hex, base64, and json encoding and decoding.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
Provides: deprecated()
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -53,16 +49,19 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build

@ -1,5 +1,5 @@
--- rustc-serialize-0.3.24/Cargo.toml 2017-04-21T16:10:04+02:00
+++ rustc-serialize-0.3.24/Cargo.toml 2018-10-31T11:56:20.133187+01:00
--- rustc-serialize-0.3.24/Cargo.toml 2017-04-21T14:10:04+00:00
+++ rustc-serialize-0.3.24/Cargo.toml 2023-03-20T17:59:00.023986+00:00
@@ -13,6 +13,7 @@
`derive(RustcEncodable, RustcDecodable)` mode in the compiler. Also includes
support for hex, base64, and json encoding and decoding.
@ -7,5 +7,4 @@
+exclude = ["/.travis.yml", "/appveyor.yml"]
[dev-dependencies]
-rand = "0.3"
+rand = "0.4"
rand = "0.3"

Loading…
Cancel
Save