You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-rusqlite/rusqlite-fix-metadata.diff

66 lines
1.7 KiB

--- rusqlite-0.28.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ rusqlite-0.28.0/Cargo.toml 2023-11-29T19:12:54.996906+00:00
@@ -83,7 +83,7 @@
optional = true
[dependencies.fallible-iterator]
-version = "0.2"
+version = "0.3"
[dependencies.fallible-streaming-iterator]
version = "0.1"
@@ -149,23 +149,6 @@
backup = ["libsqlite3-sys/min_sqlite_version_3_6_23"]
blob = ["libsqlite3-sys/min_sqlite_version_3_7_7"]
buildtime_bindgen = ["libsqlite3-sys/buildtime_bindgen"]
-bundled = [
- "libsqlite3-sys/bundled",
- "modern_sqlite",
-]
-bundled-full = [
- "modern-full",
- "bundled",
-]
-bundled-sqlcipher = [
- "libsqlite3-sys/bundled-sqlcipher",
- "bundled",
-]
-bundled-sqlcipher-vendored-openssl = [
- "libsqlite3-sys/bundled-sqlcipher-vendored-openssl",
- "bundled-sqlcipher",
-]
-bundled-windows = ["libsqlite3-sys/bundled-windows"]
collation = []
column_decltype = []
csvtab = [
@@ -176,10 +159,6 @@
functions = ["libsqlite3-sys/min_sqlite_version_3_7_7"]
hooks = []
i128_blob = []
-in_gecko = [
- "modern_sqlite",
- "libsqlite3-sys/in_gecko",
-]
limits = []
load_extension = []
modern-full = [
@@ -207,7 +186,7 @@
"vtab",
"window",
]
-modern_sqlite = ["libsqlite3-sys/bundled_bindings"]
+modern_sqlite = []
release_memory = ["libsqlite3-sys/min_sqlite_version_3_7_16"]
series = ["vtab"]
session = [
@@ -218,9 +197,7 @@
trace = ["libsqlite3-sys/min_sqlite_version_3_6_23"]
unlock_notify = ["libsqlite3-sys/unlock_notify"]
vtab = ["libsqlite3-sys/min_sqlite_version_3_7_7"]
-wasm32-wasi-vfs = ["libsqlite3-sys/wasm32-wasi-vfs"]
window = ["functions"]
-winsqlite3 = ["libsqlite3-sys/winsqlite3"]
with-asan = ["libsqlite3-sys/with-asan"]
[badges.appveyor]