You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-rtoolbox/rust-rtoolbox.spec

89 lines
2.1 KiB

# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate rtoolbox
Name: rust-rtoolbox
Version: 0.0.1
Release: %autorelease
Summary: Utility functions for other crates, no backwards compatibility guarantees
License: Apache-2.0 AND MIT
URL: https://crates.io/crates/rtoolbox
Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies
Patch: rtoolbox-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * correct license in crate metadata:
# https://github.com/conradkleinespel/duck/pull/51
Patch: rtoolbox-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Utility functions for other crates, no backwards compatibility
guarantees.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%doc %{crate_instdir}/CONTRIBUTING.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog