You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-rstest_macros/rust-rstest_macros.spec

96 lines
2.3 KiB

# Generated by rust2rpm 26
# * Tests require the previous version of rstest.
%bcond_with check
%global debug_package %{nil}
%global crate rstest_macros
Name: rust-rstest_macros
Version: 0.23.0
Release: %autorelease
Summary: Rust fixture based test framework
License: MIT OR Apache-2.0
URL: https://crates.io/crates/rstest_macros
Source: %{crates_source}
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Rust fixture based test framework. It use procedural macro to implement
fixtures and table based tests.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+async-timeout-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+async-timeout-devel %{_description}
This package contains library source intended for building other packages which
use the "async-timeout" feature of the "%{crate}" crate.
%files -n %{name}+async-timeout-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+crate-name-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+crate-name-devel %{_description}
This package contains library source intended for building other packages which
use the "crate-name" feature of the "%{crate}" crate.
%files -n %{name}+crate-name-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog