You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-rspec/rust-rspec.spec

76 lines
1.7 KiB

# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate rspec
Name: rust-rspec
Version: 1.0.0
Release: %autorelease
Summary: Write Rspec-like tests with stable rust
License: MPL-2.0
URL: https://crates.io/crates/rspec
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * remove optional build-dependency on the obsolete clippy crate
# * remove unused optional feature for expectest compatibility
# * bump derive-new dependency from 0.5 to 0.6
# * bump derive_builder dependency from 0.9 to 0.20
# * bump time dependency from 0.2 to 0.3
Patch: rspec-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Write Rspec-like tests with stable rust.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog