import rust-rkyv-0.8.9-1.el10

i10ce changed/i10ce/rust-rkyv-0.8.9-1.el10
MSVSphere Packaging Team 2 months ago
commit 753ee01ee4
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/rkyv-0.8.9.crate

@ -0,0 +1 @@
5ce39fbd5fc0474550aa8f284dec723d5fd576c9 SOURCES/rkyv-0.8.9.crate

@ -0,0 +1,140 @@
--- rkyv-0.8.9/Cargo.toml 1970-01-01T00:00:01+00:00
+++ rkyv-0.8.9/Cargo.toml 2024-12-16T14:22:32.740455+00:00
@@ -77,10 +77,6 @@
name = "derive"
path = "tests/derive.rs"
-[[test]]
-name = "ui"
-path = "tests/ui.rs"
-
[[bench]]
name = "log"
path = "benches/log.rs"
@@ -96,40 +92,16 @@
path = "benches/minecraft_savedata.rs"
harness = false
-[dependencies.arrayvec-0_7]
-version = "0.7"
-optional = true
-default-features = false
-package = "arrayvec"
-
[dependencies.bytecheck]
version = "0.8"
features = ["simdutf8"]
optional = true
default-features = false
-[dependencies.bytes-1]
-version = "1"
-optional = true
-default-features = false
-package = "bytes"
-
[dependencies.hashbrown]
version = "0.15"
optional = true
default-features = false
-
-[dependencies.hashbrown-0_14]
-version = "0.14"
-optional = true
-default-features = false
-package = "hashbrown"
-
-[dependencies.indexmap-2]
-version = "2"
-optional = true
-default-features = false
-package = "indexmap"
[dependencies.munge]
version = "0.4"
@@ -151,48 +123,6 @@
version = "=0.8.9"
default-features = false
-[dependencies.smallvec-1]
-version = "1"
-optional = true
-default-features = false
-package = "smallvec"
-
-[dependencies.smol_str-0_2]
-version = "0.2"
-optional = true
-default-features = false
-package = "smol_str"
-
-[dependencies.smol_str-0_3]
-version = "0.3"
-optional = true
-default-features = false
-package = "smol_str"
-
-[dependencies.thin-vec-0_2]
-version = "0.2.12"
-optional = true
-default-features = false
-package = "thin-vec"
-
-[dependencies.tinyvec-1]
-version = "1"
-optional = true
-default-features = false
-package = "tinyvec"
-
-[dependencies.triomphe-0_1]
-version = "0.1"
-optional = true
-default-features = false
-package = "triomphe"
-
-[dependencies.uuid-1]
-version = "1"
-optional = true
-default-features = false
-package = "uuid"
-
[dev-dependencies.ahash]
version = "0.8"
@@ -212,7 +142,6 @@
aligned = []
alloc = [
"dep:hashbrown",
- "tinyvec-1?/alloc",
"rancor/alloc",
]
big_endian = []
@@ -225,28 +154,12 @@
"std",
"bytecheck",
]
-hashbrown-0_15 = ["dep:hashbrown"]
-indexmap-2 = [
- "dep:indexmap-2",
- "alloc",
-]
little_endian = []
pointer_width_16 = []
pointer_width_32 = []
pointer_width_64 = []
std = [
"alloc",
- "bytes-1?/std",
- "indexmap-2?/std",
"ptr_meta/std",
- "uuid-1?/std",
-]
-triomphe-0_1 = [
- "dep:triomphe-0_1",
- "alloc",
]
unaligned = []
-uuid-1 = [
- "dep:uuid-1",
- "bytecheck?/uuid-1",
-]

@ -0,0 +1,27 @@
[package]
cargo-toml-patch-comments = [
"""\
Where possible, patch out \"support for common crates\" features. Many of \
these have satisfiable dependencies and could be packaged if something \
specifically requires them. Upstream plans to remove these \
crate-integration features in 1.0: \
https://github.com/rkyv/rkyv/blob/89a1bc48229ca6ac5ee620964d778293270257d0/rkyv/Cargo.toml#L29-L32\
""",
"""\
Patch out the ui test, which seems to require *all* integrations, even the \
patched-out ones\
""",
]
[requires]
build = [
"dos2unix",
"tomcli",
]
[scripts.prep]
pre = [
"# Do not depend on divan; it is needed only for benchmarks.",
"tomcli set Cargo.toml del dev-dependencies.divan",
]

@ -0,0 +1,325 @@
## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 27
%bcond check 1
%global debug_package %{nil}
%global crate rkyv
Name: rust-rkyv
Version: 0.8.9
Release: %autorelease
Summary: Zero-copy deserialization framework for Rust
License: MIT
URL: https://crates.io/crates/rkyv
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * Where possible, patch out "support for common crates" features. Many of
# these have satisfiable dependencies and could be packaged if something
# specifically requires them. Upstream plans to remove these crate-integration
# features in 1.0:
# https://github.com/rkyv/rkyv/blob/89a1bc48229ca6ac5ee620964d778293270257d0/rkyv/Cargo.toml#L29-L32
# * Patch out the ui test, which seems to require *all* integrations, even the
# patched-out ones
Patch: rkyv-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
BuildRequires: dos2unix
BuildRequires: tomcli
%global _description %{expand:
Zero-copy deserialization framework for Rust.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+aligned-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+aligned-devel %{_description}
This package contains library source intended for building other packages which
use the "aligned" feature of the "%{crate}" crate.
%files -n %{name}+aligned-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+big_endian-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+big_endian-devel %{_description}
This package contains library source intended for building other packages which
use the "big_endian" feature of the "%{crate}" crate.
%files -n %{name}+big_endian-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bytecheck-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bytecheck-devel %{_description}
This package contains library source intended for building other packages which
use the "bytecheck" feature of the "%{crate}" crate.
%files -n %{name}+bytecheck-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+little_endian-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+little_endian-devel %{_description}
This package contains library source intended for building other packages which
use the "little_endian" feature of the "%{crate}" crate.
%files -n %{name}+little_endian-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+pointer_width_16-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+pointer_width_16-devel %{_description}
This package contains library source intended for building other packages which
use the "pointer_width_16" feature of the "%{crate}" crate.
%files -n %{name}+pointer_width_16-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+pointer_width_32-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+pointer_width_32-devel %{_description}
This package contains library source intended for building other packages which
use the "pointer_width_32" feature of the "%{crate}" crate.
%files -n %{name}+pointer_width_32-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+pointer_width_64-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+pointer_width_64-devel %{_description}
This package contains library source intended for building other packages which
use the "pointer_width_64" feature of the "%{crate}" crate.
%files -n %{name}+pointer_width_64-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unaligned-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unaligned-devel %{_description}
This package contains library source intended for building other packages which
use the "unaligned" feature of the "%{crate}" crate.
%files -n %{name}+unaligned-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
# Do not depend on divan; it is needed only for benchmarks.
tomcli set Cargo.toml del dev-dependencies.divan
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.8.9-1
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Mon Dec 16 2024 Fabio Valentini <decathorpe@gmail.com> - 0.8.9-1
- Update to version 0.8.9; Fixes RHBZ#2328715
* Tue Oct 08 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.8.8-1
- Update to version 0.8.8; Fixes RHBZ#2311783
- Add upstream link for fixing mixture of newline styles
- Backport commit from upstream to fix s390x issues
- Where possible, patch out "support for common crates" features
* Fri Aug 30 2024 Fabio Valentini <decathorpe@gmail.com> - 0.7.45-1
- Update to version 0.7.45; Fixes RHBZ#2306089
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.44-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Sat Apr 13 2024 Fabio Valentini <decathorpe@gmail.com> - 0.7.44-1
- Update to version 0.7.44; Fixes RHBZ#2262581
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.43-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Sun Jan 14 2024 Fabio Valentini <decathorpe@gmail.com> - 0.7.43-1
- Update to version 0.7.43; Fixes RHBZ#2254897
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.42-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Mon May 22 2023 Fabio Valentini <decathorpe@gmail.com> - 0.7.42-1
- Update to version 0.7.42; Fixes RHBZ#2203535
* Sun Apr 02 2023 Fabio Valentini <decathorpe@gmail.com> - 0.7.41-1
- Update to version 0.7.41; Fixes RHBZ#2183438
* Tue Feb 28 2023 Fabio Valentini <decathorpe@gmail.com> - 0.7.40-1
- Update to version 0.7.40; Fixes RHBZ#2169603
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.39-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.39-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Sat Jul 16 2022 Fabio Valentini <decathorpe@gmail.com> - 0.7.39-1
- Update to version 0.7.39; Fixes RHBZ#2101255
* Mon Jun 06 2022 Fabio Valentini <decathorpe@gmail.com> - 0.7.38-1
- Update to version 0.7.38; Fixes RHBZ#2064099
* Fri Apr 08 2022 Rémi <remilauzier@protonmail.com> - 0.7.37-1
- Update to version 0.7.37; Fixes RHBZ#2064099
* Fri Mar 04 2022 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.35-2
- Downgrade hashbrown to version 0.11
* Fri Mar 04 2022 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.35-1
- Update to version 0.7.35; Fixes RHBZ#2054999
* Thu Jan 27 2022 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.31-1
- Update to version 0.7.31; Fixes RHBZ#2046578
* Wed Jan 26 2022 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.30-1
- Update to version 0.7.30; Fixes RHBZ#2038518
* Tue Jan 25 2022 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.29-1
- Update to version 0.7.29; Fixes RHBZ#2038518
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.28-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Tue Dec 28 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.28-1
- Update to version 0.7.28; Fixes RHBZ#2033937
* Sun Dec 19 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.27-2
- Disable doc-test for now
* Sat Dec 18 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.27-1
- Update to version 0.7.27; Fixes RHBZ#2028959
* Fri Dec 10 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.26-1
- Update to version 0.7.26; Fixes RHBZ#2028959
* Tue Nov 30 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.24-1
- Update to version 0.7.24; Fixes RHBZ#2025214
* Fri Oct 29 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.20-1
- Update to version 0.7.20; Fixes RHBZ#2011054
* Wed Sep 22 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.18-1
- Update to version 0.7.18; Fixes RHBZ#2004726
* Wed Sep 15 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.17-1
- Update to version 0.7.17; Fixes RHBZ#2003852
* Sun Sep 05 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.16-1
- Update to version 0.7.16; Fixes RHBZ#1998663
* Wed Aug 25 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.13-1
- Update to version 0.7.13; Fixes RHBZ#1996127
* Mon Aug 16 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.11-1
- Update to version 0.7.11; Fixes RHBZ#1990969
* Fri Aug 06 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.5-3
- Add the patch
* Fri Aug 06 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.5-2
- Deactivate test on s390x and armv7hl
* Thu Aug 05 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.7.5-1
- Initial import; Fixes RHBZ#1980592
## END: Generated by rpmautospec
Loading…
Cancel
Save