Remove ExcludeArch but only compile on supported architectures

epel9
Fabio Valentini 2 years ago
parent 4203d54451
commit 778d059dc2
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,5 +1,5 @@
--- ring-0.16.20/Cargo.toml 2021-02-01T22:20:41+00:00
+++ ring-0.16.20/Cargo.toml 2023-03-18T22:05:06.357486+00:00
+++ ring-0.16.20/Cargo.toml 2023-04-01T14:08:54.743609+00:00
@@ -60,10 +60,6 @@
std = ["alloc"]
test_logging = []

@ -1,5 +1,5 @@
--- ring-0.16.20/Cargo.toml 2021-02-01T22:20:41+00:00
+++ ring-0.16.20/Cargo.toml 2023-03-18T22:06:09.210728+00:00
+++ ring-0.16.20/Cargo.toml 2023-04-01T14:09:25.801749+00:00
@@ -23,25 +23,10 @@
readme = "doc/link-to-readme.md"
keywords = ["crypto", "cryptography", "rand", "ECC", "RSA"]

@ -4,6 +4,10 @@
%global crate ring
# compile and run tests only on supported architectures
# https://bugzilla.redhat.com/show_bug.cgi?id=1869980
%global supported_arches x86_64 %{ix86} aarch64 %{arm}
Name: rust-ring
Version: 0.16.20
Release: %autorelease
@ -20,10 +24,6 @@ Patch: ring-fix-metadata-auto.diff
# * set package.license in metadata to match package license
Patch: ring-fix-metadata.diff
# * ring does not support ppc64le and s390x:
# https://bugzilla.redhat.com/show_bug.cgi?id=1869980
ExcludeArch: ppc64le s390x
BuildRequires: rust-packaging >= 21
%global _description %{expand:
@ -161,17 +161,21 @@ use the "wasm32_c" feature of the "%{crate}" crate.
%cargo_generate_buildrequires
%build
%ifarch %{supported_arches}
%cargo_build
%endif
%install
%cargo_install
%if %{with check}
%ifarch %{supported_arches}
%check
# * files needed for integration tests are not included in published crates
%cargo_test -- --lib
%cargo_test -- --doc
%endif
%endif
%changelog
%autochangelog

@ -0,0 +1,6 @@
[DEFAULT]
supported-arches =
x86_64
%{ix86}
aarch64
%{arm}
Loading…
Cancel
Save