You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
145 lines
3.6 KiB
145 lines
3.6 KiB
# Generated by rust2rpm 26
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate rgb
|
|
|
|
Name: rust-rgb
|
|
Version: 0.8.50
|
|
Release: %autorelease
|
|
Summary: Struct RGB/RGBA/etc. for sharing pixels between crates
|
|
|
|
License: MIT
|
|
URL: https://crates.io/crates/rgb
|
|
Source: %{crates_source}
|
|
|
|
BuildRequires: cargo-rpm-macros >= 24
|
|
|
|
%global _description %{expand:
|
|
`struct RGB/RGBA/etc.` for sharing pixels between crates + convenience
|
|
methods for color manipulation. Allows no-copy high-level
|
|
interoperability. Also adds common convenience methods and implements
|
|
standard Rust traits to make `RGB`/`RGBA` pixels and slices first-class
|
|
Rust objects.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+argb-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+argb-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "argb" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+argb-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+as-bytes-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+as-bytes-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "as-bytes" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+as-bytes-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+bytemuck-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+bytemuck-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "bytemuck" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+bytemuck-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+checked_fns-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+checked_fns-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "checked_fns" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+checked_fns-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+grb-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+grb-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "grb" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+grb-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+serde-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+serde-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "serde" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+serde-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
%autochangelog
|