parent
d8138d7ff4
commit
cabe248745
@ -1 +1,2 @@
|
||||
/resolv-conf-0.6.2.crate
|
||||
/resolv-conf-0.6.3.crate
|
||||
|
@ -1,52 +0,0 @@
|
||||
From c0305a3e4b08d740eb6702b69e9eee079a84fd0a Mon Sep 17 00:00:00 2001
|
||||
From: Luca BRUNO <luca.bruno@coreos.com>
|
||||
Date: Thu, 27 Feb 2020 10:50:36 +0000
|
||||
Subject: [PATCH] cargo: update to latest hostname version
|
||||
|
||||
This updates the optional `hostname` dependency to the latest
|
||||
version (0.3.0).
|
||||
|
||||
Signed-off-by: Luca BRUNO <luca.bruno@coreos.com>
|
||||
---
|
||||
src/config.rs | 12 +++++++-----
|
||||
1 file changed, 7 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/src/config.rs b/src/config.rs
|
||||
index 36b6185..f0074ae 100644
|
||||
--- a/src/config.rs
|
||||
+++ b/src/config.rs
|
||||
@@ -4,9 +4,6 @@ use std::slice::Iter;
|
||||
use {grammar, Network, ParseError, ScopedIp};
|
||||
use std::net::{IpAddr, Ipv4Addr, Ipv6Addr};
|
||||
|
||||
-#[cfg(feature = "system")]
|
||||
-use hostname::get_hostname;
|
||||
-
|
||||
const NAMESERVER_LIMIT:usize = 3;
|
||||
const SEARCH_LIMIT:usize = 6;
|
||||
|
||||
@@ -278,14 +275,19 @@ impl Config {
|
||||
return self.domain.clone();
|
||||
}
|
||||
|
||||
- get_hostname().and_then(|s| {
|
||||
+ let hostname = match ::hostname::get().ok() {
|
||||
+ Some(name) => name.into_string().ok(),
|
||||
+ None => return None,
|
||||
+ };
|
||||
+
|
||||
+ hostname.and_then(|s| {
|
||||
if let Some(pos) = s.find('.') {
|
||||
let hn = s[pos + 1..].to_string();
|
||||
if !hn.is_empty() {
|
||||
return Some(hn)
|
||||
}
|
||||
};
|
||||
- return None;
|
||||
+ None
|
||||
})
|
||||
}
|
||||
}
|
||||
--
|
||||
2.25.1
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- resolv-conf-0.6.2/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ resolv-conf-0.6.2/Cargo.toml 2020-02-28T12:07:29.374198+00:00
|
||||
@@ -26,7 +26,7 @@
|
||||
name = "resolv_conf"
|
||||
path = "src/lib.rs"
|
||||
[dependencies.hostname]
|
||||
-version = "0.1.5"
|
||||
+version = "0.3"
|
||||
optional = true
|
||||
|
||||
[dependencies.quick-error]
|
@ -1 +1 @@
|
||||
SHA512 (resolv-conf-0.6.2.crate) = 5065fffb8fcc6afb2c42ee82cb09ebe879605e6ef2a6f02decf4892967730271bf4e798de02fdf37b4b55b0610f76689ef749ca85870b6656669af4cfd859473
|
||||
SHA512 (resolv-conf-0.6.3.crate) = 063affa9aae0231234cc0d685971a86dcd2f6a8311d46f65a3df17414fcffd8b923b2f72f4ccf540e738c17959d53b36f0d0f585ba63d9de119c082e313e153f
|
||||
|
Loading…
Reference in new issue