You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-reqwest/reqwest-fix-metadata.diff

127 lines
2.8 KiB

--- reqwest-0.12.5/Cargo.toml 1970-01-01T00:00:01+00:00
+++ reqwest-0.12.5/Cargo.toml 2024-07-03T21:36:21.631788+00:00
@@ -70,10 +70,6 @@
path = "examples/form.rs"
[[example]]
-name = "h3_simple"
-path = "examples/h3_simple.rs"
-
-[[example]]
name = "json_dynamic"
path = "examples/json_dynamic.rs"
required-features = ["json"]
@@ -100,14 +96,6 @@
name = "blocking"
path = "tests/blocking.rs"
required-features = ["blocking"]
-
-[[test]]
-name = "brotli"
-path = "tests/brotli.rs"
-required-features = [
- "brotli",
- "stream",
-]
[[test]]
name = "client"
@@ -222,7 +210,6 @@
"hyper-rustls?/ring",
"tokio-rustls?/ring",
"rustls?/ring",
- "quinn?/ring",
]
__tls = [
"dep:rustls-pemfile",
@@ -235,11 +222,6 @@
"futures-util/sink",
"tokio/sync",
]
-brotli = [
- "dep:async-compression",
- "async-compression?/brotli",
- "dep:tokio-util",
-]
charset = ["dep:encoding_rs"]
cookies = [
"dep:cookie_crate",
@@ -249,7 +231,6 @@
"default-tls",
"charset",
"http2",
- "macos-system-configuration",
]
default-tls = [
"dep:hyper-tls",
@@ -274,16 +255,7 @@
"hyper-util/http2",
"hyper-rustls?/http2",
]
-http3 = [
- "rustls-tls-manual-roots",
- "dep:h3",
- "dep:h3-quinn",
- "dep:quinn",
- "dep:slab",
- "dep:futures-channel",
-]
json = ["dep:serde_json"]
-macos-system-configuration = []
multipart = ["dep:mime_guess"]
native-tls = ["default-tls"]
native-tls-alpn = [
@@ -291,10 +263,6 @@
"native-tls-crate?/alpn",
"hyper-tls?/alpn",
]
-native-tls-vendored = [
- "native-tls",
- "native-tls-crate?/vendored",
-]
rustls-tls = ["rustls-tls-webpki-roots"]
rustls-tls-manual-roots = [
"__rustls",
@@ -353,14 +321,6 @@
version = "0.4"
optional = true
-[target.'cfg(not(target_arch = "wasm32"))'.dependencies.h3]
-version = "0.0.5"
-optional = true
-
-[target.'cfg(not(target_arch = "wasm32"))'.dependencies.h3-quinn]
-version = "0.0.6"
-optional = true
-
[target.'cfg(not(target_arch = "wasm32"))'.dependencies.hickory-resolver]
version = "0.24"
features = ["tokio-runtime"]
@@ -424,15 +384,6 @@
[target.'cfg(not(target_arch = "wasm32"))'.dependencies.pin-project-lite]
version = "0.2.11"
-[target.'cfg(not(target_arch = "wasm32"))'.dependencies.quinn]
-version = "0.11.1"
-features = [
- "rustls",
- "runtime-tokio",
-]
-optional = true
-default-features = false
-
[target.'cfg(not(target_arch = "wasm32"))'.dependencies.rustls]
version = "0.23.4"
features = [
@@ -493,10 +444,6 @@
[target.'cfg(not(target_arch = "wasm32"))'.dependencies.webpki-roots]
version = "0.26.0"
optional = true
-
-[target.'cfg(not(target_arch = "wasm32"))'.dev-dependencies.brotli_crate]
-version = "3.3.0"
-package = "brotli"
[target.'cfg(not(target_arch = "wasm32"))'.dev-dependencies.doc-comment]
version = "0.3"