Update to version 0.12.4; Fixes RHBZ#2269208

epel10
Fabio Valentini 10 months ago
parent 0db453668c
commit ee0a09f49a
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -30,3 +30,4 @@
/reqwest-0.11.23.crate
/reqwest-0.11.24.crate
/reqwest-0.11.25.crate
/reqwest-0.12.4.crate

@ -1,16 +1,25 @@
--- reqwest-0.11.25/Cargo.toml 1970-01-01T00:00:01+00:00
+++ reqwest-0.11.25/Cargo.toml 2024-03-09T10:15:59.345616+00:00
@@ -222,7 +222,6 @@
--- reqwest-0.12.4/Cargo.toml 1970-01-01T00:00:01+00:00
+++ reqwest-0.12.4/Cargo.toml 2024-04-19T22:19:11.305463+00:00
@@ -228,7 +228,7 @@
"hyper-util/http2",
]
json = ["dep:serde_json"]
-macos-system-configuration = ["dep:system-configuration"]
+macos-system-configuration = []
multipart = ["dep:mime_guess"]
native-tls = ["default-tls"]
native-tls-alpn = [
@@ -254,7 +254,6 @@
stream = [
"tokio/fs",
"tokio-util",
- "wasm-streams",
]
trust-dns = ["trust-dns-resolver"]
@@ -412,51 +411,3 @@
"dep:tokio-util",
- "dep:wasm-streams",
]
default-features = false
trust-dns = []
zstd = [
@@ -475,52 +474,3 @@
version = "0.13"
package = "zstd"
-[target."cfg(target_arch = \"wasm32\")".dependencies.js-sys]
-version = "0.3.45"
@ -56,7 +65,8 @@
-version = "0.3"
-
-[target."cfg(target_os = \"macos\")".dependencies.system-configuration]
-version = "0.6"
-version = "0.5.1"
-optional = true
-
-[target."cfg(windows)".dependencies.winreg]
-version = "0.50.0"
-version = "0.52.0"

@ -0,0 +1,18 @@
--- reqwest-0.12.4/Cargo.toml 1970-01-01T00:00:01+00:00
+++ reqwest-0.12.4/Cargo.toml 2024-04-19T22:19:30.447563+00:00
@@ -203,7 +203,6 @@
"default-tls",
"charset",
"http2",
- "macos-system-configuration",
]
default-tls = [
"dep:hyper-tls",
@@ -228,7 +227,6 @@
"hyper-util/http2",
]
json = ["dep:serde_json"]
-macos-system-configuration = []
multipart = ["dep:mime_guess"]
native-tls = ["default-tls"]
native-tls-alpn = [

@ -5,7 +5,7 @@
%global crate reqwest
Name: rust-reqwest
Version: 0.11.25
Version: 0.12.4
Release: %autorelease
Summary: Higher level HTTP client library
@ -14,6 +14,9 @@ URL: https://crates.io/crates/reqwest
Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: reqwest-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop macOS-specific features
Patch: reqwest-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
@ -86,18 +89,6 @@ use the "__tls" feature of the "%{crate}" crate.
%files -n %{name}+__tls-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+async-compression-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+async-compression-devel %{_description}
This package contains library source intended for building other packages which
use the "async-compression" feature of the "%{crate}" crate.
%files -n %{name}+async-compression-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+blocking-devel
Summary: %{summary}
BuildArch: noarch
@ -122,28 +113,16 @@ use the "brotli" feature of the "%{crate}" crate.
%files -n %{name}+brotli-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+cookie_crate-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+cookie_crate-devel %{_description}
This package contains library source intended for building other packages which
use the "cookie_crate" feature of the "%{crate}" crate.
%files -n %{name}+cookie_crate-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+cookie_store-devel
%package -n %{name}+charset-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+cookie_store-devel %{_description}
%description -n %{name}+charset-devel %{_description}
This package contains library source intended for building other packages which
use the "cookie_store" feature of the "%{crate}" crate.
use the "charset" feature of the "%{crate}" crate.
%files -n %{name}+cookie_store-devel
%files -n %{name}+charset-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+cookies-devel
@ -206,64 +185,40 @@ use the "gzip" feature of the "%{crate}" crate.
%files -n %{name}+gzip-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+h3-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+h3-devel %{_description}
This package contains library source intended for building other packages which
use the "h3" feature of the "%{crate}" crate.
%files -n %{name}+h3-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+h3-quinn-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+h3-quinn-devel %{_description}
This package contains library source intended for building other packages which
use the "h3-quinn" feature of the "%{crate}" crate.
%files -n %{name}+h3-quinn-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+http3-devel
%package -n %{name}+h2-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+http3-devel %{_description}
%description -n %{name}+h2-devel %{_description}
This package contains library source intended for building other packages which
use the "http3" feature of the "%{crate}" crate.
use the "h2" feature of the "%{crate}" crate.
%files -n %{name}+http3-devel
%files -n %{name}+h2-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+hyper-rustls-devel
%package -n %{name}+hickory-dns-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+hyper-rustls-devel %{_description}
%description -n %{name}+hickory-dns-devel %{_description}
This package contains library source intended for building other packages which
use the "hyper-rustls" feature of the "%{crate}" crate.
use the "hickory-dns" feature of the "%{crate}" crate.
%files -n %{name}+hyper-rustls-devel
%files -n %{name}+hickory-dns-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+hyper-tls-devel
%package -n %{name}+http2-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+hyper-tls-devel %{_description}
%description -n %{name}+http2-devel %{_description}
This package contains library source intended for building other packages which
use the "hyper-tls" feature of the "%{crate}" crate.
use the "http2" feature of the "%{crate}" crate.
%files -n %{name}+hyper-tls-devel
%files -n %{name}+http2-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+json-devel
@ -278,18 +233,6 @@ use the "json" feature of the "%{crate}" crate.
%files -n %{name}+json-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+mime_guess-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+mime_guess-devel %{_description}
This package contains library source intended for building other packages which
use the "mime_guess" feature of the "%{crate}" crate.
%files -n %{name}+mime_guess-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+multipart-devel
Summary: %{summary}
BuildArch: noarch
@ -326,52 +269,16 @@ use the "native-tls-alpn" feature of the "%{crate}" crate.
%files -n %{name}+native-tls-alpn-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+native-tls-crate-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+native-tls-crate-devel %{_description}
This package contains library source intended for building other packages which
use the "native-tls-crate" feature of the "%{crate}" crate.
%files -n %{name}+native-tls-crate-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+quinn-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+quinn-devel %{_description}
This package contains library source intended for building other packages which
use the "quinn" feature of the "%{crate}" crate.
%files -n %{name}+quinn-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustls-devel
%package -n %{name}+rustls-pki-types-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustls-devel %{_description}
%description -n %{name}+rustls-pki-types-devel %{_description}
This package contains library source intended for building other packages which
use the "rustls" feature of the "%{crate}" crate.
use the "rustls-pki-types" feature of the "%{crate}" crate.
%files -n %{name}+rustls-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustls-native-certs-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustls-native-certs-devel %{_description}
This package contains library source intended for building other packages which
use the "rustls-native-certs" feature of the "%{crate}" crate.
%files -n %{name}+rustls-native-certs-devel
%files -n %{name}+rustls-pki-types-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustls-tls-devel
@ -422,18 +329,6 @@ use the "rustls-tls-webpki-roots" feature of the "%{crate}" crate.
%files -n %{name}+rustls-tls-webpki-roots-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde_json-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde_json-devel %{_description}
This package contains library source intended for building other packages which
use the "serde_json" feature of the "%{crate}" crate.
%files -n %{name}+serde_json-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+socks-devel
Summary: %{summary}
BuildArch: noarch
@ -458,54 +353,6 @@ use the "stream" feature of the "%{crate}" crate.
%files -n %{name}+stream-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tokio-native-tls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tokio-native-tls-devel %{_description}
This package contains library source intended for building other packages which
use the "tokio-native-tls" feature of the "%{crate}" crate.
%files -n %{name}+tokio-native-tls-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tokio-rustls-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tokio-rustls-devel %{_description}
This package contains library source intended for building other packages which
use the "tokio-rustls" feature of the "%{crate}" crate.
%files -n %{name}+tokio-rustls-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tokio-socks-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tokio-socks-devel %{_description}
This package contains library source intended for building other packages which
use the "tokio-socks" feature of the "%{crate}" crate.
%files -n %{name}+tokio-socks-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tokio-util-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tokio-util-devel %{_description}
This package contains library source intended for building other packages which
use the "tokio-util" feature of the "%{crate}" crate.
%files -n %{name}+tokio-util-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+trust-dns-devel
Summary: %{summary}
BuildArch: noarch
@ -518,28 +365,16 @@ use the "trust-dns" feature of the "%{crate}" crate.
%files -n %{name}+trust-dns-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+trust-dns-resolver-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+trust-dns-resolver-devel %{_description}
This package contains library source intended for building other packages which
use the "trust-dns-resolver" feature of the "%{crate}" crate.
%files -n %{name}+trust-dns-resolver-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+webpki-roots-devel
%package -n %{name}+zstd-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+webpki-roots-devel %{_description}
%description -n %{name}+zstd-devel %{_description}
This package contains library source intended for building other packages which
use the "webpki-roots" feature of the "%{crate}" crate.
use the "zstd" feature of the "%{crate}" crate.
%files -n %{name}+webpki-roots-devel
%files -n %{name}+zstd-devel
%ghost %{crate_instdir}/Cargo.toml
%prep

@ -1,6 +1,9 @@
[features]
hide = [
"h3",
"h3-quinn",
"native-tls-vendored",
"quinn",
]
[tests]

@ -1 +1 @@
SHA512 (reqwest-0.11.25.crate) = 9b3719562454056e1175d994af7a3438d3bb94e73b551212a31f3c12504613b69fa49d4d86023002996f8896f21e652a71afb62ab4faa2c9c6c1a2e25a7a4dd3
SHA512 (reqwest-0.12.4.crate) = fec388a448df03919563c007e83b565a8a88dfa4b208cf5ec9701eaa1d9dd1b6767b03e76b60324598f875f8d5ac971ad2ce3fa3ee032375c0fcc43a731f8cc8

Loading…
Cancel
Save