commit
a660a65699
Binary file not shown.
@ -0,0 +1,62 @@
|
||||
--- reqwest-0.11.22/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ reqwest-0.11.22/Cargo.toml 2023-11-06T11:15:47.342691+00:00
|
||||
@@ -221,7 +221,6 @@
|
||||
stream = [
|
||||
"tokio/fs",
|
||||
"tokio-util",
|
||||
- "wasm-streams",
|
||||
]
|
||||
trust-dns = ["trust-dns-resolver"]
|
||||
|
||||
@@ -403,51 +402,3 @@
|
||||
]
|
||||
default-features = false
|
||||
|
||||
-[target."cfg(target_arch = \"wasm32\")".dependencies.js-sys]
|
||||
-version = "0.3.45"
|
||||
-
|
||||
-[target."cfg(target_arch = \"wasm32\")".dependencies.serde_json]
|
||||
-version = "1.0"
|
||||
-
|
||||
-[target."cfg(target_arch = \"wasm32\")".dependencies.wasm-bindgen]
|
||||
-version = "0.2.68"
|
||||
-
|
||||
-[target."cfg(target_arch = \"wasm32\")".dependencies.wasm-bindgen-futures]
|
||||
-version = "0.4.18"
|
||||
-
|
||||
-[target."cfg(target_arch = \"wasm32\")".dependencies.wasm-streams]
|
||||
-version = "0.3"
|
||||
-optional = true
|
||||
-
|
||||
-[target."cfg(target_arch = \"wasm32\")".dependencies.web-sys]
|
||||
-version = "0.3.25"
|
||||
-features = [
|
||||
- "AbortController",
|
||||
- "AbortSignal",
|
||||
- "Headers",
|
||||
- "Request",
|
||||
- "RequestInit",
|
||||
- "RequestMode",
|
||||
- "Response",
|
||||
- "Window",
|
||||
- "FormData",
|
||||
- "Blob",
|
||||
- "BlobPropertyBag",
|
||||
- "ServiceWorkerGlobalScope",
|
||||
- "RequestCredentials",
|
||||
- "File",
|
||||
- "ReadableStream",
|
||||
-]
|
||||
-
|
||||
-[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen]
|
||||
-version = "0.2.68"
|
||||
-features = ["serde-serialize"]
|
||||
-
|
||||
-[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-test]
|
||||
-version = "0.3"
|
||||
-
|
||||
-[target."cfg(target_os = \"macos\")".dependencies.system-configuration]
|
||||
-version = "0.5.1"
|
||||
-
|
||||
-[target."cfg(windows)".dependencies.winreg]
|
||||
-version = "0.50.0"
|
@ -0,0 +1,730 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 3;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 25
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate reqwest
|
||||
|
||||
Name: rust-reqwest
|
||||
Version: 0.11.22
|
||||
Release: %autorelease
|
||||
Summary: Higher level HTTP client library
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/reqwest
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip dependencies and normalize metadata
|
||||
Patch: reqwest-fix-metadata-auto.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Higher level HTTP client library.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+__internal_proxy_sys_no_cache-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+__internal_proxy_sys_no_cache-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "__internal_proxy_sys_no_cache" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+__internal_proxy_sys_no_cache-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+__rustls-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+__rustls-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "__rustls" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+__rustls-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+__tls-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+__tls-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "__tls" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+__tls-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+async-compression-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+async-compression-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "async-compression" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+async-compression-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+blocking-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+blocking-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "blocking" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+blocking-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+brotli-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+brotli-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "brotli" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+brotli-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+cookie_crate-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+cookie_crate-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "cookie_crate" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+cookie_crate-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+cookie_store-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+cookie_store-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "cookie_store" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+cookie_store-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+cookies-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+cookies-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "cookies" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+cookies-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+default-tls-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-tls-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default-tls" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-tls-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+deflate-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+deflate-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "deflate" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+deflate-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+futures-channel-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+futures-channel-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "futures-channel" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+futures-channel-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+gzip-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+gzip-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "gzip" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+gzip-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+h3-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+h3-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "h3" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+h3-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+h3-quinn-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+h3-quinn-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "h3-quinn" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+h3-quinn-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+http3-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+http3-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "http3" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+http3-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+hyper-rustls-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+hyper-rustls-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "hyper-rustls" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+hyper-rustls-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+hyper-tls-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+hyper-tls-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "hyper-tls" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+hyper-tls-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+json-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+json-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "json" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+json-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+mime_guess-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+mime_guess-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "mime_guess" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+mime_guess-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+multipart-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+multipart-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "multipart" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+multipart-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+native-tls-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+native-tls-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "native-tls" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+native-tls-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+native-tls-alpn-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+native-tls-alpn-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "native-tls-alpn" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+native-tls-alpn-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+native-tls-crate-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+native-tls-crate-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "native-tls-crate" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+native-tls-crate-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+quinn-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+quinn-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "quinn" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+quinn-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rustls-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rustls-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rustls" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rustls-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rustls-native-certs-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rustls-native-certs-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rustls-native-certs" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rustls-native-certs-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rustls-pemfile-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rustls-pemfile-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rustls-pemfile" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rustls-pemfile-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rustls-tls-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rustls-tls-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rustls-tls" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rustls-tls-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rustls-tls-manual-roots-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rustls-tls-manual-roots-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rustls-tls-manual-roots" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rustls-tls-manual-roots-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rustls-tls-native-roots-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rustls-tls-native-roots-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rustls-tls-native-roots" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rustls-tls-native-roots-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rustls-tls-webpki-roots-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rustls-tls-webpki-roots-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rustls-tls-webpki-roots" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rustls-tls-webpki-roots-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde_json-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde_json-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde_json" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde_json-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+socks-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+socks-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "socks" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+socks-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+stream-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+stream-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "stream" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+stream-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tokio-native-tls-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tokio-native-tls-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tokio-native-tls" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tokio-native-tls-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tokio-rustls-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tokio-rustls-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tokio-rustls" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tokio-rustls-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tokio-socks-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tokio-socks-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tokio-socks" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tokio-socks-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tokio-util-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tokio-util-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tokio-util" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tokio-util-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+trust-dns-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+trust-dns-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "trust-dns" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+trust-dns-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+trust-dns-resolver-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+trust-dns-resolver-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "trust-dns-resolver" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+trust-dns-resolver-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+webpki-roots-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+webpki-roots-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "webpki-roots" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+webpki-roots-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
# * skip tests which require internet access
|
||||
%cargo_test -- -- --exact --skip test_allowed_methods --skip test_badssl_modern --skip test_badssl_self_signed --skip test_tls_info
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.11.22-3
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Mon Nov 06 2023 Fabio Valentini <decathorpe@gmail.com> - 0.11.22-3
|
||||
- Enable features for HTTP/3 (QUIC) support
|
||||
|
||||
* Sat Oct 28 2023 Fabio Valentini <decathorpe@gmail.com> - 0.11.22-2
|
||||
- Enable features for Rustls support
|
||||
|
||||
* Fri Oct 20 2023 Fabio Valentini <decathorpe@gmail.com> - 0.11.22-1
|
||||
- Update to version 0.11.22; Fixes RHBZ#2241801
|
||||
|
||||
* Thu Aug 24 2023 Fabio Valentini <decathorpe@gmail.com> - 0.11.20-1
|
||||
- Update to version 0.11.20; Fixes RHBZ#2234025
|
||||
|
||||
* Wed Aug 23 2023 Fabio Valentini <decathorpe@gmail.com> - 0.11.19-1
|
||||
- Update to version 0.11.19; Fixes RHBZ#2233319
|
||||
|
||||
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.18-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Mon Jul 17 2023 Fabio Valentini <decathorpe@gmail.com> - 0.11.18-1
|
||||
- Update to version 0.11.18; Fixes RHBZ#2207795
|
||||
|
||||
* Fri Apr 28 2023 Fabio Valentini <decathorpe@gmail.com> - 0.11.17-1
|
||||
- Update to version 0.11.17; Fixes RHBZ#2190521
|
||||
|
||||
* Thu Mar 30 2023 Fabio Valentini <decathorpe@gmail.com> - 0.11.16-1
|
||||
- Update to version 0.11.16; Fixes RHBZ#2182147
|
||||
|
||||
* Tue Mar 21 2023 Fabio Valentini <decathorpe@gmail.com> - 0.11.15-1
|
||||
- Update to version 0.11.15; Fixes RHBZ#2180105
|
||||
|
||||
* Thu Feb 23 2023 Fabio Valentini <decathorpe@gmail.com> - 0.11.14-1
|
||||
- Update to version 0.11.14; Fixes RHBZ#2143384
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.12-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Sun Oct 09 2022 Fabio Valentini <decathorpe@gmail.com> - 0.11.12-2
|
||||
- Don't drop the serde_json dependency from the json feature
|
||||
|
||||
* Wed Oct 05 2022 Fabio Valentini <decathorpe@gmail.com> - 0.11.12-1
|
||||
- Update to version 0.11.12; Fixes RHBZ#2128505
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.11-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Sun Jul 17 2022 Fabio Valentini <decathorpe@gmail.com> - 0.11.11-1
|
||||
- Update to version 0.11.11; Fixes RHBZ#2096455
|
||||
|
||||
* Fri Mar 18 2022 Fabio Valentini <decathorpe@gmail.com> - 0.11.10-1
|
||||
- Update to version 0.11.10; Fixes RHBZ#2011969
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Wed Jan 05 2022 Fabio Valentini <decathorpe@gmail.com> - 0.11.6-1
|
||||
- Update to version 0.11.6
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Tue Jun 22 2021 Fabio Valentini <decathorpe@gmail.com> - 0.11.4-1
|
||||
- Update to version 0.11.4.
|
||||
- Fixes RHBZ#1974523
|
||||
|
||||
* Fri Jun 11 2021 Fabio Valentini <decathorpe@gmail.com> - 0.11.3-1
|
||||
- Update to version 0.11.3.
|
||||
- Fixes RHBZ#1948875
|
||||
|
||||
* Tue Mar 23 2021 Fabio Valentini <decathorpe@gmail.com> - 0.11.2-1
|
||||
- Update to version 0.11.2.
|
||||
- Fixes RHBZ#1937094
|
||||
|
||||
* Sat Mar 06 2021 Fabio Valentini <decathorpe@gmail.com> - 0.11.1-1
|
||||
- Update to version 0.11.1.
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.9-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Fri Nov 27 2020 Fabio Valentini <decathorpe@gmail.com> - 0.10.9-1
|
||||
- Update to version 0.10.9.
|
||||
|
||||
* Wed Oct 21 2020 Fabio Valentini <decathorpe@gmail.com> - 0.10.8-2
|
||||
- Bump to tokio-socks 0.3.
|
||||
|
||||
* Wed Aug 26 2020 Josh Stone <jistone@redhat.com> - 0.10.8-1
|
||||
- Update to 0.10.8
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Thu Jun 04 2020 Josh Stone <jistone@redhat.com> - 0.10.6-1
|
||||
- Update to 0.10.6
|
||||
|
||||
* Mon May 18 12:49:32 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.10.4-2
|
||||
- Update libflate to 1.0
|
||||
|
||||
* Wed Mar 04 2020 Josh Stone <jistone@redhat.com> - 0.10.4-1
|
||||
- Update to 0.10.4
|
||||
|
||||
* Thu Feb 27 2020 Josh Stone <jistone@redhat.com> - 0.10.3-1
|
||||
- Update to 0.10.3
|
||||
|
||||
* Fri Feb 21 2020 Josh Stone <jistone@redhat.com> - 0.10.2-1
|
||||
- Update to 0.10.2
|
||||
|
||||
* Tue Feb 11 10:17:33 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.10.1-1
|
||||
- Update to 0.10.1
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.24-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Thu Dec 26 07:19:05 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.9.24-1
|
||||
- Update to 0.9.24
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.13-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Fri Jun 21 18:20:27 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.9.13-2
|
||||
- Regenerate
|
||||
|
||||
* Tue Apr 02 2019 Josh Stone <jistone@redhat.com> - 0.9.13-1
|
||||
- Update to 0.9.13
|
||||
|
||||
* Thu Mar 21 00:24:21 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.9.12-1
|
||||
- Update to 0.9.12
|
||||
|
||||
* Tue Mar 05 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.9.11-1
|
||||
- Update to 0.9.11
|
||||
|
||||
* Tue Feb 19 2019 Josh Stone <jistone@redhat.com> - 0.9.10-1
|
||||
- Update to 0.9.10
|
||||
|
||||
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.9-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Sat Jan 26 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.9.9-2
|
||||
- Run tests in infrastructure
|
||||
|
||||
* Sat Jan 26 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.9.9-1
|
||||
- Initial package
|
||||
|
Loading…
Reference in new issue