You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
89 lines
2.3 KiB
89 lines
2.3 KiB
# Generated by rust2rpm 26
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate relative-path
|
|
|
|
Name: rust-relative-path
|
|
Version: 1.9.3
|
|
Release: %autorelease
|
|
Summary: Portable, relative paths for Rust
|
|
|
|
License: MIT OR Apache-2.0
|
|
URL: https://crates.io/crates/relative-path
|
|
Source: %{crates_source}
|
|
# * Missing Apache-2.0 license text; see “Add license files to the crate
|
|
# tarballs,” https://github.com/udoprog/relative-path/pull/60
|
|
Source10: https://github.com/udoprog/relative-path/raw/refs/tags/%{version}/LICENSE-APACHE
|
|
# * Missing MIT license text; see “Add license files to the crate tarballs,”
|
|
# https://github.com/udoprog/relative-path/pull/60
|
|
Source11: https://github.com/udoprog/relative-path/raw/refs/tags/%{version}/LICENSE-MIT
|
|
|
|
BuildRequires: cargo-rpm-macros >= 24
|
|
|
|
%global _description %{expand:
|
|
Portable, relative paths for Rust.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE-APACHE
|
|
%license %{crate_instdir}/LICENSE-MIT
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+serde-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+serde-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "serde" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+serde-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version} -p1
|
|
cp -p '%{SOURCE10}' '%{SOURCE11}' .
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires -a
|
|
|
|
%build
|
|
%cargo_build -a
|
|
|
|
%install
|
|
%cargo_install -a
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test -a
|
|
%endif
|
|
|
|
%changelog
|
|
%autochangelog
|