Initial import

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 0b4c37a991
commit e41e699750
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -0,0 +1 @@
/regex-automata-0.1.6.crate

@ -0,0 +1,11 @@
--- regex-automata-0.1.6/Cargo.toml 1970-01-01T00:00:00+00:00
+++ regex-automata-0.1.6/Cargo.toml 2019-04-16T06:34:36.793307+00:00
@@ -14,7 +14,7 @@
name = "regex-automata"
version = "0.1.6"
authors = ["Andrew Gallant <jamslam@gmail.com>"]
-exclude = ["/.travis.yml", "/appveyor.yml", "/ci/*", "/scripts/*", "/regex-automata-debug"]
+exclude = ["/.travis.yml", "/appveyor.yml", "/ci/*", "/scripts/*", "/regex-automata-debug", "/data/*"]
autotests = false
description = "Automata construction and matching using regular expressions."
homepage = "https://github.com/BurntSushi/regex-automata"

@ -0,0 +1,119 @@
# Generated by rust2rpm
%bcond_with check
%global debug_package %{nil}
%global crate regex-automata
Name: rust-%{crate}
Version: 0.1.6
Release: 1%{?dist}
Summary: Automata construction and matching using regular expressions
# Upstream license specification: Unlicense/MIT
License: Unlicense or MIT
URL: https://crates.io/crates/regex-automata
Source: %{crates_source}
# Initial patched metadata
# * Exclude test files
Patch0: regex-automata-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: (crate(byteorder) >= 1.2.7 with crate(byteorder) < 2.0.0)
BuildRequires: (crate(regex-syntax/default) >= 0.6.4 with crate(regex-syntax/default) < 0.7.0)
BuildRequires: (crate(utf8-ranges/default) >= 1.0.0 with crate(utf8-ranges/default) < 2.0.0)
%if %{with check}
BuildRequires: (crate(lazy_static/default) >= 1.2.0 with crate(lazy_static/default) < 2.0.0)
BuildRequires: (crate(regex/default) >= 1.1.0 with crate(regex/default) < 2.0.0)
BuildRequires: (crate(serde/default) >= 1.0.82 with crate(serde/default) < 2.0.0)
BuildRequires: (crate(serde_bytes/default) >= 0.10.4 with crate(serde_bytes/default) < 0.11.0)
BuildRequires: (crate(serde_derive/default) >= 1.0.82 with crate(serde_derive/default) < 2.0.0)
BuildRequires: (crate(toml/default) >= 0.4.10 with crate(toml/default) < 0.5.0)
%endif
%global _description \
Automata construction and matching using regular expressions.
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
%files devel
%license LICENSE-MIT UNLICENSE COPYING
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+regex-syntax-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+regex-syntax-devel %{_description}
This package contains library source intended for building other packages
which use "regex-syntax" feature of "%{crate}" crate.
%files -n %{name}+regex-syntax-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages
which use "std" feature of "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+utf8-ranges-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+utf8-ranges-devel %{_description}
This package contains library source intended for building other packages
which use "utf8-ranges" feature of "%{crate}" crate.
%files -n %{name}+utf8-ranges-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Tue Apr 16 08:34:36 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.6-1
- Initial package

@ -0,0 +1 @@
SHA512 (regex-automata-0.1.6.crate) = 2e438167ef10459cb1f7ab7afe0297e3a93e34b8195d631206c804b4fc5498e03df243531df282928fb2b3bc4ab8dd0a15a101f9aa368c104fc24df190e85f14

@ -0,0 +1,5 @@
---
standard-inventory-qcow2:
qemu:
# `cargo test` usually eats more than 1G.
m: 4G

@ -0,0 +1,13 @@
---
- hosts: localhost
roles:
- role: standard-test-basic
tags:
- classic
repositories:
- repo: "https://src.fedoraproject.org/tests/rust.git"
dest: rust
tests:
- rust/cargo-test
environment:
pkg: rust-regex-automata
Loading…
Cancel
Save