Update to version 0.3.2; Fixes RHBZ#2062858

epel9
Fabio Valentini 2 years ago
parent ef65a636f7
commit 1c97000098
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -3,3 +3,4 @@
/regex-automata-0.1.8.crate
/regex-automata-0.1.9.crate
/regex-automata-0.1.10.crate
/regex-automata-0.3.2.crate

@ -1,11 +1,10 @@
--- regex-automata-0.1.10/Cargo.toml 1970-01-01T00:00:00+00:00
+++ regex-automata-0.1.10/Cargo.toml 2023-05-25T18:18:57.088337+00:00
@@ -14,7 +14,7 @@
name = "regex-automata"
version = "0.1.10"
authors = ["Andrew Gallant <jamslam@gmail.com>"]
-exclude = ["/.travis.yml", "/appveyor.yml", "/ci/*", "/scripts/*", "/regex-automata-debug"]
+exclude = ["/.travis.yml", "/appveyor.yml", "/ci/*", "/scripts/*", "/regex-automata-debug", "/data/*"]
autoexamples = false
autotests = false
description = "Automata construction and matching using regular expressions."
--- regex-automata-0.3.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ regex-automata-0.3.2/Cargo.toml 2023-07-12T13:56:55.632415+00:00
@@ -31,6 +31,7 @@
categories = ["text-processing"]
license = "MIT OR Apache-2.0"
repository = "https://github.com/rust-lang/regex/tree/master/regex-automata"
+exclude = ["/test/"]
[lib]
bench = false

@ -5,19 +5,18 @@
%global crate regex-automata
Name: rust-regex-automata
Version: 0.1.10
Version: 0.3.2
Release: %autorelease
Summary: Automata construction and matching using regular expressions
# Upstream license specification: Unlicense/MIT
License: Unlicense OR MIT
License: MIT OR Apache-2.0
URL: https://crates.io/crates/regex-automata
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * prevent test data from being installed
Patch: regex-automata-fix-metadata.diff
BuildRequires: rust-packaging >= 21
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Automata construction and matching using regular expressions.}
@ -34,11 +33,9 @@ This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/COPYING
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%license %{crate_instdir}/UNLICENSE
%doc %{crate_instdir}/README.md
%doc %{crate_instdir}/TODO
%{crate_instdir}/
%package -n %{name}+default-devel
@ -53,16 +50,232 @@ use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+regex-syntax-devel
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+regex-syntax-devel %{_description}
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which
use the "regex-syntax" feature of the "%{crate}" crate.
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+regex-syntax-devel
%files -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dfa-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dfa-devel %{_description}
This package contains library source intended for building other packages which
use the "dfa" feature of the "%{crate}" crate.
%files -n %{name}+dfa-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dfa-build-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dfa-build-devel %{_description}
This package contains library source intended for building other packages which
use the "dfa-build" feature of the "%{crate}" crate.
%files -n %{name}+dfa-build-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dfa-onepass-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dfa-onepass-devel %{_description}
This package contains library source intended for building other packages which
use the "dfa-onepass" feature of the "%{crate}" crate.
%files -n %{name}+dfa-onepass-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dfa-search-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dfa-search-devel %{_description}
This package contains library source intended for building other packages which
use the "dfa-search" feature of the "%{crate}" crate.
%files -n %{name}+dfa-search-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+hybrid-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+hybrid-devel %{_description}
This package contains library source intended for building other packages which
use the "hybrid" feature of the "%{crate}" crate.
%files -n %{name}+hybrid-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+internal-instrument-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+internal-instrument-devel %{_description}
This package contains library source intended for building other packages which
use the "internal-instrument" feature of the "%{crate}" crate.
%files -n %{name}+internal-instrument-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+internal-instrument-pikevm-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+internal-instrument-pikevm-devel %{_description}
This package contains library source intended for building other packages which
use the "internal-instrument-pikevm" feature of the "%{crate}" crate.
%files -n %{name}+internal-instrument-pikevm-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+logging-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+logging-devel %{_description}
This package contains library source intended for building other packages which
use the "logging" feature of the "%{crate}" crate.
%files -n %{name}+logging-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+meta-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+meta-devel %{_description}
This package contains library source intended for building other packages which
use the "meta" feature of the "%{crate}" crate.
%files -n %{name}+meta-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+nfa-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+nfa-devel %{_description}
This package contains library source intended for building other packages which
use the "nfa" feature of the "%{crate}" crate.
%files -n %{name}+nfa-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+nfa-backtrack-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+nfa-backtrack-devel %{_description}
This package contains library source intended for building other packages which
use the "nfa-backtrack" feature of the "%{crate}" crate.
%files -n %{name}+nfa-backtrack-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+nfa-pikevm-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+nfa-pikevm-devel %{_description}
This package contains library source intended for building other packages which
use the "nfa-pikevm" feature of the "%{crate}" crate.
%files -n %{name}+nfa-pikevm-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+nfa-thompson-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+nfa-thompson-devel %{_description}
This package contains library source intended for building other packages which
use the "nfa-thompson" feature of the "%{crate}" crate.
%files -n %{name}+nfa-thompson-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+perf-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+perf-devel %{_description}
This package contains library source intended for building other packages which
use the "perf" feature of the "%{crate}" crate.
%files -n %{name}+perf-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+perf-inline-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+perf-inline-devel %{_description}
This package contains library source intended for building other packages which
use the "perf-inline" feature of the "%{crate}" crate.
%files -n %{name}+perf-inline-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+perf-literal-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+perf-literal-devel %{_description}
This package contains library source intended for building other packages which
use the "perf-literal" feature of the "%{crate}" crate.
%files -n %{name}+perf-literal-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+perf-literal-multisubstring-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+perf-literal-multisubstring-devel %{_description}
This package contains library source intended for building other packages which
use the "perf-literal-multisubstring" feature of the "%{crate}" crate.
%files -n %{name}+perf-literal-multisubstring-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+perf-literal-substring-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+perf-literal-substring-devel %{_description}
This package contains library source intended for building other packages which
use the "perf-literal-substring" feature of the "%{crate}" crate.
%files -n %{name}+perf-literal-substring-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
@ -77,6 +290,126 @@ use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+syntax-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+syntax-devel %{_description}
This package contains library source intended for building other packages which
use the "syntax" feature of the "%{crate}" crate.
%files -n %{name}+syntax-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unicode-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unicode-devel %{_description}
This package contains library source intended for building other packages which
use the "unicode" feature of the "%{crate}" crate.
%files -n %{name}+unicode-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unicode-age-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unicode-age-devel %{_description}
This package contains library source intended for building other packages which
use the "unicode-age" feature of the "%{crate}" crate.
%files -n %{name}+unicode-age-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unicode-bool-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unicode-bool-devel %{_description}
This package contains library source intended for building other packages which
use the "unicode-bool" feature of the "%{crate}" crate.
%files -n %{name}+unicode-bool-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unicode-case-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unicode-case-devel %{_description}
This package contains library source intended for building other packages which
use the "unicode-case" feature of the "%{crate}" crate.
%files -n %{name}+unicode-case-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unicode-gencat-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unicode-gencat-devel %{_description}
This package contains library source intended for building other packages which
use the "unicode-gencat" feature of the "%{crate}" crate.
%files -n %{name}+unicode-gencat-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unicode-perl-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unicode-perl-devel %{_description}
This package contains library source intended for building other packages which
use the "unicode-perl" feature of the "%{crate}" crate.
%files -n %{name}+unicode-perl-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unicode-script-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unicode-script-devel %{_description}
This package contains library source intended for building other packages which
use the "unicode-script" feature of the "%{crate}" crate.
%files -n %{name}+unicode-script-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unicode-segment-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unicode-segment-devel %{_description}
This package contains library source intended for building other packages which
use the "unicode-segment" feature of the "%{crate}" crate.
%files -n %{name}+unicode-segment-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unicode-word-boundary-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unicode-word-boundary-devel %{_description}
This package contains library source intended for building other packages which
use the "unicode-word-boundary" feature of the "%{crate}" crate.
%files -n %{name}+unicode-word-boundary-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

@ -1,4 +0,0 @@
[DEFAULT]
unwanted-features =
fst
transducer

@ -1 +1 @@
SHA512 (regex-automata-0.1.10.crate) = 56d64da361afce82c6cb49e70b99ce1fca3e1969c54bba5f9971db135f8544c65f49feb8827789947b3d1dcefc9c49a7a434a7ffe0d09c5900345a1733723c5f
SHA512 (regex-automata-0.3.2.crate) = 82fbf0ad8a97b71c5489c69b34a3641dd104e02fc783df62036acb55ff7b6458349ae47164fda691178a054862ed00c26e471c9158391b65f9c383e38f8a5d61

Loading…
Cancel
Save