Update to 1.0.0

epel9
Josh Stone 7 years ago
parent c76a16bd47
commit ccf960bae9

1
.gitignore vendored

@ -1 +1,2 @@
/rayon-0.9.0.crate
/rayon-1.0.0.crate

@ -1,11 +0,0 @@
--- rayon-0.9.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ rayon-0.9.0/Cargo.toml 2017-12-31T15:33:56.527213+01:00
@@ -34,7 +34,7 @@
version = "0.8"
[dev-dependencies.rand]
-version = "0.3"
+version = "0.4"
[dev-dependencies.serde]
version = "1"

@ -0,0 +1,8 @@
--- rayon-1.0.0/Cargo.toml 1969-12-31T16:00:00-08:00
+++ rayon-1.0.0/Cargo.toml 2018-02-19T22:42:24.155322-08:00
@@ -41,5 +41,3 @@
[dev-dependencies.serde_derive]
version = "1"
-[target."cfg(not(all(windows, target_env = \"gnu\")))".dev-dependencies.compiletest_rs]
-version = "0.3"

@ -6,28 +6,29 @@
%global crate rayon
Name: rust-%{crate}
Version: 0.9.0
Release: 5%{?dist}
Version: 1.0.0
Release: 1%{?dist}
Summary: Simple work-stealing parallelism for Rust
License: ASL 2.0 or MIT
URL: https://crates.io/crates/rayon
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Bump rand to 0.4, https://github.com/rayon-rs/rayon/pull/502
Patch0: rayon-0.9.0-fix-metadata.diff
# * Manually trim the cfg'ed dev-dependencies.compiletest_rs
Patch0: rayon-1.0.0-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(either) >= 1.0.0 with crate(either) < 2.0.0)
BuildRequires: (crate(rayon-core) >= 1.3.0 with crate(rayon-core) < 2.0.0)
BuildRequires: (crate(rayon-core) >= 1.4.0 with crate(rayon-core) < 2.0.0)
%if %{with check}
# [dev-dependencies]
BuildRequires: (crate(compiletest_rs) >= 0.3.0 with crate(compiletest_rs) < 0.4.0)
BuildRequires: (crate(docopt) >= 0.8.0 with crate(docopt) < 0.9.0)
BuildRequires: (crate(rand) >= 0.4.0 with crate(rand) < 0.5.0)
BuildRequires: (crate(lazy_static) >= 1.0.0 with crate(lazy_static) < 2.0.0)
BuildRequires: (crate(rand) >= 0.3.0 with crate(rand) < 0.5.0)
BuildRequires: (crate(serde) >= 1.0.0 with crate(serde) < 2.0.0)
BuildRequires: (crate(serde_derive) >= 1.0.0 with crate(serde_derive) < 2.0.0)
%endif
@ -62,11 +63,14 @@ which use %{crate} from crates.io.
%files devel
%license LICENSE-APACHE LICENSE-MIT
%doc README.md RELEASES.md
%doc README.md RELEASES.md FAQ.md
%{cargo_registry}/%{crate}-%{version}/
%exclude %{cargo_registry}/%{crate}-%{version}/{appveyor.yml,bors.toml,ci,scripts}
%changelog
* Tue Feb 20 2018 Josh Stone <jistone@redhat.com> - 1.0.0-1
- Update to 1.0.0
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

@ -1 +1 @@
SHA512 (rayon-0.9.0.crate) = e85433ea326f800d9161f128b35fd623eaa75dd79aae207771175ff6e518716556bdacd7627a455ff4bf0007c4f3003bbc1fb90116dd55250392698c1e84ac79
SHA512 (rayon-1.0.0.crate) = 2781814e9254382dd7154e7a61678d7533ac4319489754ae351cf2f58e50410a2305f5c006af60f3f2447599a8ece464fd80cb871aeaccc49e0c360e647b408f

Loading…
Cancel
Save