Update to 1.0.2

epel9
Josh Stone 7 years ago
parent 0c359bf6c7
commit 908978963b

1
.gitignore vendored

@ -1,3 +1,4 @@
/rayon-0.9.0.crate
/rayon-1.0.0.crate
/rayon-1.0.1.crate
/rayon-1.0.2.crate

@ -1,17 +0,0 @@
--- rayon-1.0.1/Cargo.toml 1970-01-01T01:00:00+01:00
+++ rayon-1.0.1/Cargo.toml 2018-06-14T08:25:13.102151+02:00
@@ -28,7 +28,7 @@
[dependencies.rayon-core]
version = "1.4"
[dev-dependencies.docopt]
-version = "0.8"
+version = "1"
[dev-dependencies.lazy_static]
version = "1"
@@ -41,5 +41,3 @@
[dev-dependencies.serde_derive]
version = "1"
-[target."cfg(not(all(windows, target_env = \"gnu\")))".dev-dependencies.compiletest_rs]
-version = "0.3"

@ -0,0 +1,11 @@
--- rayon-1.0.2/Cargo.toml 1969-12-31T16:00:00-08:00
+++ rayon-1.0.2/Cargo.toml 2018-07-16T23:01:04.994635-07:00
@@ -23,7 +23,7 @@
license = "Apache-2.0/MIT"
repository = "https://github.com/rayon-rs/rayon"
[dependencies.crossbeam-deque]
-version = "0.2.0"
+version = "0.4"
[dependencies.either]
version = "1.0"

@ -1,34 +1,33 @@
# Generated by rust2rpm
# compiletest_rs is nightly, and some tests use nightly features too
%bcond_with check
%bcond_without check
%global debug_package %{nil}
%global crate rayon
Name: rust-%{crate}
Version: 1.0.1
Release: 3%{?dist}
Version: 1.0.2
Release: 1%{?dist}
Summary: Simple work-stealing parallelism for Rust
License: ASL 2.0 or MIT
URL: https://crates.io/crates/rayon
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * remove compiletest_rs (nightly only)
# * Bump docopt to 1, https://github.com/rayon-rs/rayon/pull/577
Patch0: rayon-1.0.1-fix-metadata.diff
# * Bump crossbeam-deque to 0.4, upstream doesn't want this
Patch0: rayon-1.0.2-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(crossbeam-deque) >= 0.4.0 with crate(crossbeam-deque) < 0.5.0)
BuildRequires: (crate(either) >= 1.0.0 with crate(either) < 2.0.0)
BuildRequires: (crate(rayon-core) >= 1.4.0 with crate(rayon-core) < 2.0.0)
%if %{with check}
# [dev-dependencies]
BuildRequires: (crate(docopt) >= 1.0.0 with crate(docopt) < 2.0.0)
BuildRequires: (crate(lazy_static) >= 1.0.0 with crate(lazy_static) < 2.0.0)
BuildRequires: (crate(rand) >= 0.3.0 with crate(rand) < 0.5.0)
BuildRequires: (crate(rand) >= 0.5.0 with crate(rand) < 0.6.0)
BuildRequires: (crate(serde) >= 1.0.0 with crate(serde) < 2.0.0)
BuildRequires: (crate(serde_derive) >= 1.0.0 with crate(serde_derive) < 2.0.0)
%endif
@ -68,6 +67,9 @@ which use %{crate} from crates.io.
%exclude %{cargo_registry}/%{crate}-%{version}/{appveyor.yml,bors.toml,ci,scripts}
%changelog
* Tue Jul 17 2018 Josh Stone <jistone@redhat.com> - 1.0.2-1
- Update to 1.0.2
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

@ -1 +1 @@
SHA512 (rayon-1.0.1.crate) = 0827880a1f9eeeac8c0ce12b7911237ff44b8bc586bf59d98841fe5088986a1d0e81ca91cf05cfb53dfbe77dfdc5abf18fb89aac69b152ae4ac630cf29c64229
SHA512 (rayon-1.0.2.crate) = a0e51a34c2eb54b167b4be87bf349919cb8e5d78b4158e13f74327e7dbb22d39e48a75ceaa145327ce23d0e2620201ab86751b023df5cf5ad37181cab3db6599

Loading…
Cancel
Save