Update to 1.4.1

epel9
Josh Stone 7 years ago
parent 86ae751e69
commit e160ddc45e

1
.gitignore vendored

@ -1,2 +1,3 @@
/rayon-core-1.3.0.crate
/rayon-core-1.4.0.crate
/rayon-core-1.4.1.crate

@ -1,11 +0,0 @@
--- rayon-core-1.4.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ rayon-core-1.4.0/Cargo.toml 2018-06-16T12:41:07.410169+02:00
@@ -24,7 +24,7 @@
license = "Apache-2.0/MIT"
repository = "https://github.com/rayon-rs/rayon"
[dependencies.crossbeam-deque]
-version = "0.2.0"
+version = "0.4"
[dependencies.lazy_static]
version = "1"

@ -0,0 +1,11 @@
--- rayon-core-1.4.1/Cargo.toml 1969-12-31T16:00:00-08:00
+++ rayon-core-1.4.1/Cargo.toml 2018-07-16T22:18:30.971732-07:00
@@ -45,7 +45,7 @@
name = "simple_panic"
path = "tests/simple_panic.rs"
[dependencies.crossbeam-deque]
-version = "0.2.0"
+version = "0.4"
[dependencies.lazy_static]
version = "1"

@ -1,13 +1,13 @@
# Generated by rust2rpm
# Tests require #![cfg_attr(test, feature(conservative_impl_trait))]
# Some tests don't work with optimized builds
%bcond_with check
%global debug_package %{nil}
%global crate rayon-core
Name: rust-%{crate}
Version: 1.4.0
Release: 3%{?dist}
Version: 1.4.1
Release: 1%{?dist}
Summary: Core APIs for Rayon
License: ASL 2.0 or MIT
@ -15,7 +15,7 @@ URL: https://crates.io/crates/rayon-core
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Bump crossbeam-deque to 0.4, upstream doesn't want this
Patch0: rayon-core-1.4.0-fix-metadata.diff
Patch0: rayon-core-1.4.1-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -25,7 +25,10 @@ BuildRequires: (crate(crossbeam-deque) >= 0.4.0 with crate(crossbeam-deque) < 0
BuildRequires: (crate(lazy_static) >= 1.0.0 with crate(lazy_static) < 2.0.0)
BuildRequires: (crate(libc) >= 0.2.16 with crate(libc) < 0.3.0)
BuildRequires: (crate(num_cpus) >= 1.2.0 with crate(num_cpus) < 2.0.0)
BuildRequires: (crate(rand) >= 0.3.0 with crate(rand) < 0.5.0)
%if %{with check}
# [dev-dependencies]
BuildRequires: (crate(rand) >= 0.5.0 with crate(rand) < 0.6.0)
%endif
%description
%{summary}.
@ -61,6 +64,9 @@ which use %{crate} from crates.io.
%{cargo_registry}/%{crate}-%{version}/
%changelog
* Tue Jul 17 2018 Josh Stone <jistone@redhat.com> - 1.4.1-1
- Update to 1.4.1
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

@ -1 +1 @@
SHA512 (rayon-core-1.4.0.crate) = cc8bb71068e01753dfe937cade32fd3565d85516b6d346b1ec5d2b6a0e3a753e8db9cb221acd36ff583d9aeba70ac9061ed3e1c820cbbaa23524c1aed4234879
SHA512 (rayon-core-1.4.1.crate) = 4d12b8097356d0a9eac8b3ca64085de8d19360dae81b3ccb199275c3487f705e2aded498e819958bb81d4de56c05d4d29c21c07da02236ba6fa0b2888ecfbea8

Loading…
Cancel
Save