Mark bincode as dev-dependency

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent fc5469cf68
commit 7c635a9f2c
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -0,0 +1,23 @@
--- rand_pcg-0.1.1/Cargo.toml 1970-01-01T01:00:00+01:00
+++ rand_pcg-0.1.1/Cargo.toml 2018-12-12T08:18:37.666798+01:00
@@ -23,9 +23,9 @@
categories = ["algorithms", "no-std"]
license = "MIT/Apache-2.0"
repository = "https://github.com/rust-random/small-rngs"
-[dependencies.bincode]
+[dev-dependencies.bincode]
version = "1"
-optional = true
+features = ["i128"]
[dependencies.rand_core]
version = "0.3"
@@ -42,7 +42,7 @@
version = "0.2"
[features]
-serde1 = ["serde", "serde_derive", "bincode/i128"]
+serde1 = ["serde", "serde_derive"]
[badges.appveyor]
repository = "rust-random/small-rngs"

@ -7,23 +7,28 @@
Name: rust-%{crate}
Version: 0.1.1
Release: 2%{?dist}
Release: 3%{?dist}
Summary: Selected PCG random number generators
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/rand_pcg
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Mark bincode as dev-dependency, https://github.com/rust-random/rand/issues/663
Patch0: rand_pcg-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: (crate(bincode/default) >= 1.0.0 with crate(bincode/default) < 2.0.0)
BuildRequires: (crate(bincode/i128) >= 1.0.0 with crate(bincode/i128) < 2.0.0)
BuildRequires: (crate(rand_core) >= 0.3.0 with crate(rand_core) < 0.4.0)
BuildRequires: (crate(rustc_version/default) >= 0.2.0 with crate(rustc_version/default) < 0.3.0)
BuildRequires: (crate(serde/default) >= 1.0.0 with crate(serde/default) < 2.0.0)
BuildRequires: (crate(serde_derive/default) >= 1.0.38 with crate(serde_derive/default) < 2.0.0)
%if %{with check}
BuildRequires: (crate(bincode/default) >= 1.0.0 with crate(bincode/default) < 2.0.0)
BuildRequires: (crate(bincode/i128) >= 1.0.0 with crate(bincode/i128) < 2.0.0)
%endif
%global _description \
Selected PCG random number generators.
@ -56,18 +61,6 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+bincode-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bincode-devel %{_description}
This package contains library source intended for building other packages
which use "bincode" feature of "%{crate}" crate.
%files -n %{name}+bincode-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
@ -120,6 +113,9 @@ which use "serde_derive" feature of "%{crate}" crate.
%endif
%changelog
* Wed Dec 12 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.1-3
- Mark bincode as dev-dependency
* Sat Dec 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.1-2
- Run tests in infrastructure

Loading…
Cancel
Save