Initial import

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent fce6f06963
commit 6e1440e388
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -0,0 +1 @@
/rand_jitter-0.1.4.crate

@ -0,0 +1,15 @@
--- rand_jitter-0.1.4/Cargo.toml 1970-01-01T00:00:00+00:00
+++ rand_jitter-0.1.4/Cargo.toml 2019-08-04T12:13:43.432813+00:00
@@ -29,12 +29,6 @@
[features]
std = ["rand_core/std"]
-[target."cfg(any(target_os = \"macos\", target_os = \"ios\"))".dependencies.libc]
-version = "0.2"
-default_features = false
-[target."cfg(target_os = \"windows\")".dependencies.winapi]
-version = "0.3"
-features = ["profileapi"]
[badges.appveyor]
repository = "rust-random/rand"

@ -0,0 +1,102 @@
# Generated by rust2rpm 10
%bcond_without check
%global debug_package %{nil}
%global crate rand_jitter
Name: rust-%{crate}0.1
Version: 0.1.4
Release: 1%{?dist}
Summary: Random number generator based on timing jitter
# Upstream license specification: MIT OR Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/rand_jitter
Source: %{crates_source}
# Initial patched metadata
# * No non-unix deps
Patch0: rand_jitter-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
%global _description %{expand:
Random number generator based on timing jitter.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE COPYRIGHT
%doc README.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+log-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+log-devel %{_description}
This package contains library source intended for building other packages
which use "log" feature of "%{crate}" crate.
%files -n %{name}+log-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages
which use "std" feature of "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Sun Aug 04 14:13:43 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.4-1
- Initial package

@ -0,0 +1 @@
SHA512 (rand_jitter-0.1.4.crate) = fe3791612cf82bd0ad1a115c442b4a007141647eecd48f49dff9a5d326c374663d9bd2e511c8d292e1dba44665359b522cd5d57ccd3a18598e88e42ee1670e4a

@ -0,0 +1,5 @@
---
standard-inventory-qcow2:
qemu:
# `cargo test` usually eats more than 1G.
m: 4G

@ -0,0 +1,13 @@
---
- hosts: localhost
roles:
- role: standard-test-basic
tags:
- classic
repositories:
- repo: "https://src.fedoraproject.org/tests/rust.git"
dest: rust
tests:
- rust/cargo-test
environment:
pkg: rust-rand_jitter0.1
Loading…
Cancel
Save