import rust-rand_core-0.9.0-1.el10

i10ce changed/i10ce/rust-rand_core-0.9.0-1.el10
MSVSphere Packaging Team 1 week ago
parent b0c051544b
commit f0d8c54e41
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

2
.gitignore vendored

@ -1 +1 @@
SOURCES/rand_core-0.6.4.crate
SOURCES/rand_core-0.9.0.crate

@ -1 +1 @@
97e18722c501d144ca836e60a4715fd1427ab7d1 SOURCES/rand_core-0.6.4.crate
2d3f80394d4a7e644f15377824883accab4c6682 SOURCES/rand_core-0.9.0.crate

@ -1,4 +1,4 @@
From 687722bb07677758ca463eba433e9fecc32038ee Mon Sep 17 00:00:00 2001
From ad2c05599ed3b8feff277cf8339f4cff9a48342d Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Fri, 5 Apr 2024 11:40:43 +0200
Subject: [PATCH] drop deny(warnings) from doctests
@ -8,18 +8,18 @@ Subject: [PATCH] drop deny(warnings) from doctests
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/lib.rs b/src/lib.rs
index 1234a56..de7a009 100644
index 9faff9c7..87c57bfa 100644
--- a/src/lib.rs
+++ b/src/lib.rs
@@ -34,7 +34,7 @@
@@ -31,7 +31,7 @@
)]
#![deny(missing_docs)]
#![deny(missing_debug_implementations)]
-#![doc(test(attr(allow(unused_variables), deny(warnings))))]
+#![doc(test(attr(allow(unused_variables))))]
#![cfg_attr(doc_cfg, feature(doc_cfg))]
#![cfg_attr(docsrs, feature(doc_auto_cfg))]
#![no_std]
--
2.44.0
2.48.1

@ -0,0 +1,6 @@
[[package.extra-patches]]
number = 10
file = "0001-drop-deny-warnings-from-doctests.patch"
comments = [
"drop deny(warnings) from doctests to fix building with recent Rust",
]

@ -1,33 +1,31 @@
## START: Set by rpmautospec
## (rpmautospec version 0.7.1)
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 6;
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 22
%bcond_without check
# Generated by rust2rpm 27
%bcond check 1
%global debug_package %{nil}
%global crate rand_core
Name: rust-rand_core
Version: 0.6.4
Version: 0.9.0
Release: %autorelease
Summary: Core random number generator traits and tools for implementation
License: MIT OR Apache-2.0
URL: https://crates.io/crates/rand_core
Source: %{crates_source}
# drop deny(warnings) from doctests to fix building with recent Rust
Patch: 0001-drop-deny-warnings-from-doctests.patch
# * drop deny(warnings) from doctests to fix building with recent Rust
Patch10: 0001-drop-deny-warnings-from-doctests.patch
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging >= 21
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Core random number generator traits and tools for implementation.}
@ -63,28 +61,16 @@ use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
%package -n %{name}+os_rng-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
%description -n %{name}+os_rng-devel %{_description}
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
use the "os_rng" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+getrandom-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+getrandom-devel %{_description}
This package contains library source intended for building other packages which
use the "getrandom" feature of the "%{crate}" crate.
%files -n %{name}+getrandom-devel
%files -n %{name}+os_rng-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
@ -99,18 +85,6 @@ use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde1-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde1-devel %{_description}
This package contains library source intended for building other packages which
use the "serde1" feature of the "%{crate}" crate.
%files -n %{name}+serde1-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
@ -124,7 +98,7 @@ use the "std" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
@ -142,10 +116,16 @@ use the "std" feature of the "%{crate}" crate.
%endif
%changelog
## START: Generated by rpmautospec
* Wed Jan 29 2025 Benjamin A. Beasley <code@musicinmybrain.net> - 0.9.0-1
- Update to version 0.9.0; Fixes RHBZ#2342269
* Sun Jan 19 2025 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.4-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_42_Mass_Rebuild
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.6.4-6
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.4-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild

Loading…
Cancel
Save