You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-rand0.4/rand-fix-metadata.diff

29 lines
876 B

--- rand-0.4.6/Cargo.toml 1970-01-01T00:00:00+00:00
+++ rand-0.4.6/Cargo.toml 2019-06-22T07:50:01.804117+00:00
@@ -22,6 +22,7 @@
categories = ["algorithms"]
license = "MIT/Apache-2.0"
repository = "https://github.com/rust-lang-nursery/rand"
+exclude = ["/utils/*", "/.travis.yml", "/appveyor.yml"]
[features]
alloc = []
@@ -29,17 +30,6 @@
i128_support = []
nightly = ["i128_support"]
std = ["libc"]
-[target."cfg(target_env = \"sgx\")".dependencies.rand_core]
-version = "0.3"
-default-features = false
-
-[target."cfg(target_env = \"sgx\")".dependencies.rdrand]
-version = "0.4.0"
-[target."cfg(target_os = \"fuchsia\")".dependencies.fuchsia-cprng]
-version = "0.1.0"
[target."cfg(unix)".dependencies.libc]
version = "0.2"
optional = true
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-features = ["minwindef", "ntsecapi", "profileapi", "winnt"]