commit
28f18b90a0
@ -0,0 +1,4 @@
|
||||
/rand-0.3.17.crate
|
||||
/rand-0.3.18.crate
|
||||
/rand-0.4.1.crate
|
||||
/rand-0.4.2.crate
|
@ -0,0 +1,22 @@
|
||||
--- rand-0.4.2/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||
+++ rand-0.4.2/Cargo.toml 2018-01-06T13:44:52.496038+01:00
|
||||
@@ -22,6 +22,7 @@
|
||||
categories = ["algorithms"]
|
||||
license = "MIT/Apache-2.0"
|
||||
repository = "https://github.com/rust-lang-nursery/rand"
|
||||
+exclude = ["utils/*.py"]
|
||||
|
||||
[features]
|
||||
alloc = []
|
||||
@@ -29,11 +30,6 @@
|
||||
i128_support = []
|
||||
nightly = ["i128_support"]
|
||||
std = ["libc"]
|
||||
-[target."cfg(target_os = \"fuchsia\")".dependencies.fuchsia-zircon]
|
||||
-version = "0.3.2"
|
||||
[target."cfg(unix)".dependencies.libc]
|
||||
version = "0.2"
|
||||
optional = true
|
||||
-[target."cfg(windows)".dependencies.winapi]
|
||||
-version = "0.3"
|
||||
-features = ["minwindef", "ntsecapi", "profileapi", "winnt"]
|
@ -0,0 +1,88 @@
|
||||
# Generated by rust2rpm
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate rand
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.4.2
|
||||
Release: 4%{?dist}
|
||||
Summary: Random number generators and other randomness functionality.
|
||||
|
||||
License: MIT/Apache-2.0
|
||||
URL: https://crates.io/crates/rand
|
||||
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||
# Initial patched metadata
|
||||
# * Exclude python utilities
|
||||
Patch0: rand-0.4.2-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
# [dependencies]
|
||||
BuildRequires: (crate(libc) >= 0.2.0 with crate(libc) < 0.3.0)
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel
|
||||
Random number generators and other randomness functionality.
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use %{crate} from crates.io.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%license LICENSE-MIT LICENSE-APACHE
|
||||
%doc README.md CHANGELOG.md
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
%exclude %{cargo_registry}/%{crate}-%{version}/appveyor.yml
|
||||
|
||||
%changelog
|
||||
* Tue Feb 20 2018 Josh Stone <jistone@redhat.com> - 0.4.2-4
|
||||
- Exclude python2 utilities
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.2-2
|
||||
- Rebuild for rust-packaging v5
|
||||
|
||||
* Sat Jan 06 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.2-1
|
||||
- Update to 0.4.2
|
||||
|
||||
* Sun Dec 31 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.1-1
|
||||
- Update to 0.4.1
|
||||
|
||||
* Tue Nov 07 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.18-1
|
||||
- Update to 0.3.18
|
||||
|
||||
* Fri Oct 27 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.17-1
|
||||
- Update to 0.3.17
|
||||
|
||||
* Wed Jun 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.15-3
|
||||
- Port to use rust-packaging
|
||||
|
||||
* Fri Feb 24 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.15-2
|
||||
- Use rich dependencies
|
||||
|
||||
* Sun Feb 12 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.15-1
|
||||
- Initial package
|
Loading…
Reference in new issue