Do not pull optional dependencies

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 1d4fc01843
commit ed88355deb
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -1,27 +1,6 @@
--- rand-0.6.5/Cargo.toml 1969-12-31T16:00:00-08:00
+++ rand-0.6.5/Cargo.toml 2019-01-28T14:27:08.386144-08:00
@@ -28,11 +28,6 @@
all-features = true
[dependencies.log]
version = "0.4"
-optional = true
-
-[dependencies.packed_simd]
-version = "0.3"
-features = ["into_bits"]
optional = true
[dependencies.rand_chacha]
@@ -71,18 +66,11 @@
alloc = ["rand_core/alloc"]
default = ["std"]
i128_support = []
-nightly = ["simd_support"]
serde1 = ["rand_core/serde1", "rand_isaac/serde1", "rand_xorshift/serde1"]
-simd_support = ["packed_simd"]
std = ["rand_core/std", "alloc", "rand_os", "rand_jitter/std"]
-stdweb = ["rand_os/stdweb"]
-wasm-bindgen = ["rand_os/wasm-bindgen"]
--- rand-0.6.5/Cargo.toml 1970-01-01T01:00:00+01:00
+++ rand-0.6.5/Cargo.toml 2019-03-10T11:07:34.138887+01:00
@@ -80,9 +80,6 @@
[target."cfg(unix)".dependencies.libc]
version = "0.2"
default-features = false

@ -8,14 +8,14 @@
Name: rust-%{crate}
Summary: Random number generators and other randomness functionality
Version: 0.6.5
Release: 2%{?dist}
Release: 3%{?dist}
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/rand
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
Source: %{crates_source}
# Initial patched metadata
# * Remove non-unix dependencies and nightly features
# * Remove non-unix dependencies
Patch0: rand-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -23,21 +23,17 @@ ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: (crate(autocfg/default) >= 0.1.0 with crate(autocfg/default) < 0.2.0)
BuildRequires: (crate(libc) >= 0.2.0 with crate(libc) < 0.3.0)
BuildRequires: (crate(log/default) >= 0.4.0 with crate(log/default) < 0.5.0)
BuildRequires: (crate(rand_chacha/default) >= 0.1.0 with crate(rand_chacha/default) < 0.2.0)
BuildRequires: (crate(rand_core/alloc) >= 0.4.0 with crate(rand_core/alloc) < 0.5.0)
BuildRequires: (crate(rand_core/default) >= 0.4.0 with crate(rand_core/default) < 0.5.0)
BuildRequires: (crate(rand_core/serde1) >= 0.4.0 with crate(rand_core/serde1) < 0.5.0)
BuildRequires: (crate(rand_core/std) >= 0.4.0 with crate(rand_core/std) < 0.5.0)
BuildRequires: (crate(rand_hc/default) >= 0.1.0 with crate(rand_hc/default) < 0.2.0)
BuildRequires: (crate(rand_isaac/default) >= 0.1.0 with crate(rand_isaac/default) < 0.2.0)
BuildRequires: (crate(rand_isaac/serde1) >= 0.1.0 with crate(rand_isaac/serde1) < 0.2.0)
BuildRequires: (crate(rand_jitter/default) >= 0.1.0 with crate(rand_jitter/default) < 0.2.0)
BuildRequires: (crate(rand_jitter/std) >= 0.1.0 with crate(rand_jitter/std) < 0.2.0)
BuildRequires: (crate(rand_os/default) >= 0.1.0 with crate(rand_os/default) < 0.2.0)
BuildRequires: (crate(rand_pcg/default) >= 0.1.0 with crate(rand_pcg/default) < 0.2.0)
BuildRequires: (crate(rand_xorshift/default) >= 0.1.0 with crate(rand_xorshift/default) < 0.2.0)
BuildRequires: (crate(rand_xorshift/serde1) >= 0.1.0 with crate(rand_xorshift/serde1) < 0.2.0)
%if %{with check}
BuildRequires: (crate(average/default) >= 0.9.2 with crate(average/default) < 0.10.0)
BuildRequires: (crate(rand_xoshiro/default) >= 0.1.0 with crate(rand_xoshiro/default) < 0.2.0)
@ -147,7 +143,7 @@ which use "std" feature of "%{crate}" crate.
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%build
@ -162,6 +158,9 @@ which use "std" feature of "%{crate}" crate.
%endif
%changelog
* Sun Mar 10 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.5-3
- Do not pull optional dependencies
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

Loading…
Cancel
Save