commit
8476a7c7ed
Binary file not shown.
@ -0,0 +1,11 @@
|
||||
--- radix-heap-0.4.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ radix-heap-0.4.2/Cargo.toml 2022-12-21T21:20:26.617219+00:00
|
||||
@@ -32,8 +32,6 @@
|
||||
[dependencies.ordered-float]
|
||||
version = "2.8.0"
|
||||
optional = true
|
||||
-[dev-dependencies.criterion]
|
||||
-version = "0.3.5"
|
||||
|
||||
[dev-dependencies.quickcheck]
|
||||
version = "1.0.3"
|
@ -0,0 +1,96 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.0)
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 23
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate radix-heap
|
||||
|
||||
Name: rust-radix-heap
|
||||
Version: 0.4.2
|
||||
Release: %autorelease
|
||||
Summary: Fast monotone priority queues
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/radix-heap
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# - remove criterion dev-dependency as it's only for benchmarking
|
||||
Patch: radix-heap-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Fast monotone priority queues.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+ordered-float-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+ordered-float-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "ordered-float" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+ordered-float-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.4.2-1
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Wed Jan 04 2023 Michel Alexandre Salim <salimma@fedoraproject.org> 0.4.2-1
|
||||
- Initial Fedora package
|
Loading…
Reference in new issue