You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
118 lines
2.8 KiB
118 lines
2.8 KiB
# Generated by rust2rpm 23
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate quick-xml
|
|
|
|
Name: rust-quick-xml0.17
|
|
Version: 0.17.2
|
|
Release: %autorelease
|
|
Summary: High performance xml reader and writer
|
|
|
|
License: MIT
|
|
URL: https://crates.io/crates/quick-xml
|
|
Source: %{crates_source}
|
|
|
|
BuildRequires: rust-packaging >= 21
|
|
|
|
%global _description %{expand:
|
|
High performance xml reader and writer.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE-MIT.md
|
|
%doc %{crate_instdir}/Changelog.md
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+encoding-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+encoding-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "encoding" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+encoding-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+encoding_rs-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+encoding_rs-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "encoding_rs" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+encoding_rs-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+serde-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+serde-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "serde" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+serde-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+serialize-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+serialize-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "serialize" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+serialize-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
%autochangelog
|