You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-pyo3/pyo3-fix-metadata.diff

93 lines
1.5 KiB

--- pyo3-0.15.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ pyo3-0.15.1/Cargo.toml 2022-03-12T20:34:18.419081+00:00
@@ -29,41 +29,6 @@
no-default-features = true
rustdoc-args = ["--cfg", "docsrs"]
-[[bench]]
-name = "bench_call"
-harness = false
-
-[[bench]]
-name = "bench_err"
-harness = false
-
-[[bench]]
-name = "bench_dict"
-harness = false
-
-[[bench]]
-name = "bench_gil"
-harness = false
-
-[[bench]]
-name = "bench_list"
-harness = false
-
-[[bench]]
-name = "bench_pyclass"
-harness = false
-
-[[bench]]
-name = "bench_pyobject"
-harness = false
-
-[[bench]]
-name = "bench_set"
-harness = false
-
-[[bench]]
-name = "bench_tuple"
-harness = false
[dependencies.anyhow]
version = "1.0"
optional = true
@@ -71,20 +36,16 @@
[dependencies.cfg-if]
version = "1.0"
-[dependencies.eyre]
-version = ">= 0.4, < 0.7"
-optional = true
-
[dependencies.hashbrown]
version = ">= 0.9, < 0.12"
optional = true
[dependencies.indexmap]
-version = ">= 1.6, < 1.8"
+version = "1.6"
optional = true
[dependencies.indoc]
-version = "0.3.6"
+version = "1.0.3"
optional = true
[dependencies.inventory]
@@ -106,7 +67,7 @@
version = "0.11.0"
[dependencies.paste]
-version = "0.1.18"
+version = "1.0"
optional = true
[dependencies.pyo3-macros]
@@ -124,13 +85,10 @@
version = "1.1.0"
[dev-dependencies.bitflags]
-version = "=1.2.1"
-
-[dev-dependencies.criterion]
-version = "=0.3.4"
+version = "1.2.1"
[dev-dependencies.half]
-version = "=1.7.1"
+version = "1.7.1"
[dev-dependencies.proptest]
version = "0.10.1"