Update to version 0.15.1; Fixes RHBZ#2020053

epel10
Fabio Valentini 3 years ago
parent ae56fc9940
commit 7c41e1cfde
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -6,3 +6,4 @@
/pyo3-0.13.2.crate
/pyo3-0.14.3.crate
/pyo3-0.14.5.crate
/pyo3-0.15.1.crate

@ -1,6 +1,58 @@
--- pyo3-0.14.5/Cargo.toml 1970-01-01T00:00:01+00:00
+++ pyo3-0.14.5/Cargo.toml 2021-09-05T14:15:08.717792+00:00
@@ -76,7 +76,7 @@
--- pyo3-0.15.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ pyo3-0.15.1/Cargo.toml 2021-11-22T11:18:19.902732+00:00
@@ -29,51 +29,12 @@
no-default-features = true
rustdoc-args = ["--cfg", "docsrs"]
-[[bench]]
-name = "bench_call"
-harness = false
-
-[[bench]]
-name = "bench_err"
-harness = false
-
-[[bench]]
-name = "bench_dict"
-harness = false
-
-[[bench]]
-name = "bench_gil"
-harness = false
-
-[[bench]]
-name = "bench_list"
-harness = false
-
-[[bench]]
-name = "bench_pyclass"
-harness = false
-
-[[bench]]
-name = "bench_pyobject"
-harness = false
-
-[[bench]]
-name = "bench_set"
-harness = false
-
-[[bench]]
-name = "bench_tuple"
-harness = false
[dependencies.anyhow]
version = "1.0"
optional = true
[dependencies.cfg-if]
version = "1.0"
-
-[dependencies.eyre]
-version = ">= 0.4, < 0.7"
-optional = true
[dependencies.hashbrown]
version = ">= 0.9, < 0.12"
@@ -84,7 +45,7 @@
optional = true
[dependencies.indoc]
@ -9,7 +61,7 @@
optional = true
[dependencies.inventory]
@@ -98,7 +98,7 @@
@@ -106,7 +67,7 @@
version = "0.11.0"
[dependencies.paste]
@ -18,13 +70,19 @@
optional = true
[dependencies.pyo3-macros]
@@ -114,9 +114,6 @@
optional = true
[dev-dependencies.assert_approx_eq]
@@ -124,13 +85,10 @@
version = "1.1.0"
[dev-dependencies.bitflags]
-version = "=1.2.1"
-
-[dev-dependencies.criterion]
-version = "=0.3.4"
+version = "1.2.1"
[dev-dependencies.half]
-version = "=1.7.1"
+version = "1.7.1"
[dev-dependencies.proptest]
version = "0.10.1"

@ -5,7 +5,7 @@
%global crate pyo3
Name: rust-%{crate}
Version: 0.14.5
Version: 0.15.1
Release: %autorelease
Summary: Bindings to Python interpreter
@ -17,7 +17,10 @@ Source: %{crates_source}
# * bump dependencies (MSRV 1.41 is not relevant for Fedora):
# - bump indoc from 0.3.6 to 1.0.3
# - bump paste from 0.1.18 to 1.0
# * drop criterion dev-dependency (only used in benchmarks)
# * relax exact versions for bitflags and half dev-dependencies
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
# * drop unused benchmark definitions from Cargo.toml
# * drop unused eyre feature (not packaged yet)
Patch0: pyo3-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -71,6 +74,18 @@ which use "abi3" feature of "%{crate}" crate.
%files -n %{name}+abi3-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+abi3-py310-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+abi3-py310-devel %{_description}
This package contains library source intended for building other packages
which use "abi3-py310" feature of "%{crate}" crate.
%files -n %{name}+abi3-py310-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+abi3-py36-devel
Summary: %{summary}
BuildArch: noarch
@ -123,6 +138,18 @@ which use "abi3-py39" feature of "%{crate}" crate.
%files -n %{name}+abi3-py39-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+anyhow-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+anyhow-devel %{_description}
This package contains library source intended for building other packages
which use "anyhow" feature of "%{crate}" crate.
%files -n %{name}+anyhow-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+auto-initialize-devel
Summary: %{summary}
BuildArch: noarch

@ -1 +1 @@
SHA512 (pyo3-0.14.5.crate) = 050cf757cf3d07dad46af1bfb0a0fc4b4b7ef677af15d2119ef3eb83cf0bcaa02540c7e5c04a0c0653813e6041221754d3af6b6ac6041e9287fb9d50121c5b35
SHA512 (pyo3-0.15.1.crate) = 9168911db76f2c9629615c997accfc4234bf91cc72293dcdb3db14b4e93f93af9df3b3aa7900384121719aeda4a0b6dd68c0cb380bfe5424724b0be5303c02e6

Loading…
Cancel
Save