You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
112 lines
2.8 KiB
112 lines
2.8 KiB
# Generated by rust2rpm 24
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate pulldown-cmark
|
|
|
|
Name: rust-pulldown-cmark0.8
|
|
Version: 0.8.0
|
|
Release: %autorelease
|
|
Summary: Pull parser for CommonMark
|
|
|
|
License: MIT
|
|
URL: https://crates.io/crates/pulldown-cmark
|
|
Source: %{crates_source}
|
|
# Manually created patch for downstream crate metadata changes
|
|
# * drop pulldown-cmark binary from compat package
|
|
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
|
|
# * bump html5ever dev-dependency from 0.25 to 0.26
|
|
# * bump markup5ever_rcdom dev-dependency from 0.1 to 0.2
|
|
Patch: pulldown-cmark-fix-metadata.diff
|
|
|
|
BuildRequires: rust-packaging >= 21
|
|
|
|
%global _description %{expand:
|
|
A pull parser for CommonMark.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE
|
|
%doc %{crate_instdir}/CONTRIBUTING.md
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+gen-tests-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+gen-tests-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "gen-tests" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+gen-tests-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+getopts-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+getopts-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "getopts" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+getopts-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+simd-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+simd-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "simd" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+simd-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
%autochangelog
|