You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
143 lines
4.2 KiB
143 lines
4.2 KiB
## START: Set by rpmautospec
|
|
## (rpmautospec version 0.7.3)
|
|
## RPMAUTOSPEC: autorelease, autochangelog
|
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
|
release_number = 1;
|
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
|
print(release_number + base_release_number - 1);
|
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
|
## END: Set by rpmautospec
|
|
|
|
# Generated by rust2rpm 27
|
|
%bcond check 1
|
|
%global debug_package %{nil}
|
|
|
|
%global crate psl
|
|
|
|
Name: rust-psl
|
|
Version: 2.1.78
|
|
Release: %autorelease
|
|
Summary: Extract root domain and suffix from a domain name
|
|
|
|
# Upstream license specification: MIT/Apache-2.0
|
|
License: MIT OR Apache-2.0
|
|
URL: https://crates.io/crates/psl
|
|
Source: %{crates_source}
|
|
|
|
BuildRequires: cargo-rpm-macros >= 24
|
|
|
|
%global _description %{expand:
|
|
Extract root domain and suffix from a domain name.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+helpers-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+helpers-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "helpers" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+helpers-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
## START: Generated by rpmautospec
|
|
* Tue Jan 14 2025 Fabio Valentini <decathorpe@gmail.com> - 2.1.78-1
|
|
- Update to version 2.1.78; Fixes RHBZ#2336068
|
|
|
|
* Fri Jan 03 2025 Fabio Valentini <decathorpe@gmail.com> - 2.1.73-1
|
|
- Update to version 2.1.73; Fixes RHBZ#2331307
|
|
|
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 2.1.66-1
|
|
- Rebuilt for MSVSphere 10
|
|
|
|
* Mon Dec 09 2024 Fabio Valentini <decathorpe@gmail.com> - 2.1.66-1
|
|
- Update to version 2.1.66; Fixes RHBZ#2329424
|
|
|
|
* Thu Nov 28 2024 Fabio Valentini <decathorpe@gmail.com> - 2.1.62-1
|
|
- Update to version 2.1.62; Fixes RHBZ#2326143
|
|
|
|
* Sat Jul 27 2024 Fabio Valentini <decathorpe@gmail.com> - 2.1.55-1
|
|
- Update to version 2.1.55; Fixes RHBZ#2297893
|
|
|
|
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.50-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
|
|
|
* Sat Jul 06 2024 Fabio Valentini <decathorpe@gmail.com> - 2.1.50-1
|
|
- Update to version 2.1.50; Fixes RHBZ#2294122
|
|
|
|
* Mon Jun 24 2024 Fabio Valentini <decathorpe@gmail.com> - 2.1.47-1
|
|
- Update to version 2.1.47; Fixes RHBZ#2292560
|
|
|
|
* Fri Jun 14 2024 Fabio Valentini <decathorpe@gmail.com> - 2.1.44-1
|
|
- Update to version 2.1.44; Fixes RHBZ#2291244
|
|
|
|
* Wed Jun 05 2024 Fabio Valentini <decathorpe@gmail.com> - 2.1.42-1
|
|
- Update to version 2.1.42; Fixes RHBZ#2283274
|
|
|
|
* Thu May 16 2024 Fabio Valentini <decathorpe@gmail.com> - 2.1.39-1
|
|
- Update to version 2.1.39; Fixes RHBZ#2278079
|
|
|
|
* Mon Apr 22 2024 Fabio Valentini <decathorpe@gmail.com> - 2.1.34-1
|
|
- Update to version 2.1.34; Fixes RHBZ#2274422
|
|
|
|
* Thu Apr 04 2024 Fabio Valentini <decathorpe@gmail.com> - 2.1.30-1
|
|
- Update to version 2.1.30; Fixes RHBZ#2269092
|
|
|
|
* Fri Mar 08 2024 Fabio Valentini <decathorpe@gmail.com> - 2.1.27-1
|
|
- Update to version 2.1.27; Fixes RHBZ#2259978
|
|
|
|
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.14-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
|
|
|
* Thu Jan 18 2024 Albert Larsan <albertlarsan@unbon.cafe> - 2.1.14-1
|
|
- Initial import (fedora#2254743)
|
|
## END: Generated by rpmautospec
|