You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-proptest-derive0.3/rust-proptest-derive0.3.spec

79 lines
1.9 KiB

# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate proptest-derive
Name: rust-proptest-derive0.3
Version: 0.3.0
Release: %autorelease
Summary: Custom-derive for the Arbitrary trait of proptest
# Upstream license specification: MIT/Apache-2.0
License: MIT OR Apache-2.0
URL: https://crates.io/crates/proptest-derive
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency
# * drop obsolete compiletest_rs dev-dependency
Patch: proptest-derive-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Custom-derive for the Arbitrary trait of proptest.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
# drop tests that depend on compiletest_rs
rm -v tests/compiletest.rs
rm -vr tests/compile-fail/
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog