epel9
imports/e9/rust-proptest-derive0.3-0.3.0-1.el9
parent
929deaaf68
commit
0e0c38a5cd
@ -0,0 +1 @@
|
||||
/proptest-derive-0.3.0.crate
|
@ -1,3 +0,0 @@
|
||||
# rust-proptest-derive0.3
|
||||
|
||||
The rust-proptest-derive0.3 package
|
@ -0,0 +1,15 @@
|
||||
--- proptest-derive-0.3.0/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ proptest-derive-0.3.0/Cargo.toml 2023-12-12T23:39:40.365798+00:00
|
||||
@@ -39,12 +39,6 @@
|
||||
[dependencies.syn]
|
||||
version = "0.15.17"
|
||||
features = ["visit", "extra-traits", "full"]
|
||||
-[dev-dependencies.compiletest_rs]
|
||||
-version = "0.3.19"
|
||||
-features = ["tmp", "stable"]
|
||||
-
|
||||
-[dev-dependencies.criterion]
|
||||
-version = "0.2"
|
||||
|
||||
[dev-dependencies.proptest]
|
||||
version = "1.0.0"
|
@ -0,0 +1,78 @@
|
||||
# Generated by rust2rpm 25
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate proptest-derive
|
||||
|
||||
Name: rust-proptest-derive0.3
|
||||
Version: 0.3.0
|
||||
Release: %autorelease
|
||||
Summary: Custom-derive for the Arbitrary trait of proptest
|
||||
|
||||
# Upstream license specification: MIT/Apache-2.0
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/proptest-derive
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop unused, benchmark-only criterion dev-dependency
|
||||
# * drop obsolete compiletest_rs dev-dependency
|
||||
Patch: proptest-derive-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Custom-derive for the Arbitrary trait of proptest.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
# drop tests that depend on compiletest_rs
|
||||
rm -v tests/compiletest.rs
|
||||
rm -vr tests/compile-fail/
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue