Update to version 0.5.0; Fixes RHBZ#2293796

epel10
Fabio Valentini 8 months ago
parent 0b5a9c2b75
commit 2ca3f39c9f
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -2,3 +2,4 @@
/proptest-derive-0.2.0.crate
/proptest-derive-0.3.0.crate
/proptest-derive-0.4.0.crate
/proptest-derive-0.5.0.crate

@ -1,22 +1,34 @@
--- proptest-derive-0.4.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ proptest-derive-0.4.0/Cargo.toml 2023-12-12T23:36:53.698228+00:00
@@ -34,10 +34,6 @@
[lib]
proc-macro = true
--- proptest-derive-0.5.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ proptest-derive-0.5.0/Cargo.toml 2024-06-25T21:08:52.150306+00:00
@@ -44,10 +44,6 @@
[[test]]
name = "assoc"
path = "tests/assoc.rs"
-
-[[test]]
-name = "compiletest"
-path = "tests/compiletest.rs"
[[test]]
name = "enum"
@@ -109,11 +105,6 @@
name = "weight"
path = "tests/weight.rs"
-[[bench]]
-name = "large_enum"
-path = "benches/large_enum.rs"
-harness = false
-
[dependencies.proc-macro2]
version = "1.0"
@@ -52,15 +48,5 @@
@@ -128,16 +119,6 @@
"full",
]
-[dev-dependencies.compiletest_rs]
-version = "0.9"
-version = "0.11"
-features = [
- "tmp",
- "stable",
@ -27,3 +39,4 @@
-
[dev-dependencies.proptest]
version = "1.0.0"

@ -1,11 +1,11 @@
# Generated by rust2rpm 25
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate proptest-derive
Name: rust-proptest-derive
Version: 0.4.0
Version: 0.5.0
Release: %autorelease
Summary: Custom-derive for the Arbitrary trait of proptest
@ -52,6 +52,18 @@ use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+boxed_union-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+boxed_union-devel %{_description}
This package contains library source intended for building other packages which
use the "boxed_union" feature of the "%{crate}" crate.
%files -n %{name}+boxed_union-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

@ -0,0 +1,13 @@
[package]
cargo-toml-patch-comments = [
"drop unused, benchmark-only criterion dev-dependency",
"drop obsolete compiletest_rs dev-dependency",
]
[scripts]
prep.post = [
"# drop tests that depend on compiletest_rs",
"rm -v tests/compiletest.rs",
"rm -vr tests/compile-fail/",
]

@ -1 +1 @@
SHA512 (proptest-derive-0.4.0.crate) = 6fc09a778c8e71c713d2f2ed5c647db0b5b3d50ad20820d25a5b938eed36b2ade6c2cf91a986316151384ce346d9110da0251946722650afb15a441e5a26f187
SHA512 (proptest-derive-0.5.0.crate) = 4769617f1a575b9dad158937efde4f946f8dd347ac50be5f0bdf0d922151898ebbac413d6c1991550374136e62493bc38370ff933a12c2a5e107b4deaaf3ddce

Loading…
Cancel
Save