You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-prodash/SPECS/rust-prodash.spec

376 lines
11 KiB

## START: Set by rpmautospec
## (rpmautospec version 0.3.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate prodash
Name: rust-prodash
Version: 26.2.2
Release: %autorelease
Summary: Dashboard for visualizing progress of asynchronous and possibly blocking tasks
License: MIT
URL: https://crates.io/crates/prodash
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * Drop benchmark dependency
Patch: prodash-fix-metadata.diff
BuildRequires: rust-packaging >= 21
%global _description %{expand:
A dashboard for visualizing progress of asynchronous and possibly
blocking tasks.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE.md
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+async-io-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+async-io-devel %{_description}
This package contains library source intended for building other packages which
use the "async-io" feature of the "%{crate}" crate.
%files -n %{name}+async-io-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bytesize-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bytesize-devel %{_description}
This package contains library source intended for building other packages which
use the "bytesize" feature of the "%{crate}" crate.
%files -n %{name}+bytesize-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ctrlc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ctrlc-devel %{_description}
This package contains library source intended for building other packages which
use the "ctrlc" feature of the "%{crate}" crate.
%files -n %{name}+ctrlc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dashmap-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dashmap-devel %{_description}
This package contains library source intended for building other packages which
use the "dashmap" feature of the "%{crate}" crate.
%files -n %{name}+dashmap-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+futures-core-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+futures-core-devel %{_description}
This package contains library source intended for building other packages which
use the "futures-core" feature of the "%{crate}" crate.
%files -n %{name}+futures-core-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+futures-lite-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+futures-lite-devel %{_description}
This package contains library source intended for building other packages which
use the "futures-lite" feature of the "%{crate}" crate.
%files -n %{name}+futures-lite-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+human_format-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+human_format-devel %{_description}
This package contains library source intended for building other packages which
use the "human_format" feature of the "%{crate}" crate.
%files -n %{name}+human_format-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+humantime-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+humantime-devel %{_description}
This package contains library source intended for building other packages which
use the "humantime" feature of the "%{crate}" crate.
%files -n %{name}+humantime-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+is-terminal-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+is-terminal-devel %{_description}
This package contains library source intended for building other packages which
use the "is-terminal" feature of the "%{crate}" crate.
%files -n %{name}+is-terminal-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+local-time-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+local-time-devel %{_description}
This package contains library source intended for building other packages which
use the "local-time" feature of the "%{crate}" crate.
%files -n %{name}+local-time-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+log-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+log-devel %{_description}
This package contains library source intended for building other packages which
use the "log" feature of the "%{crate}" crate.
%files -n %{name}+log-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+parking_lot-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+parking_lot-devel %{_description}
This package contains library source intended for building other packages which
use the "parking_lot" feature of the "%{crate}" crate.
%files -n %{name}+parking_lot-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+progress-log-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+progress-log-devel %{_description}
This package contains library source intended for building other packages which
use the "progress-log" feature of the "%{crate}" crate.
%files -n %{name}+progress-log-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+progress-tree-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+progress-tree-devel %{_description}
This package contains library source intended for building other packages which
use the "progress-tree" feature of the "%{crate}" crate.
%files -n %{name}+progress-tree-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+progress-tree-hp-hashmap-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+progress-tree-hp-hashmap-devel %{_description}
This package contains library source intended for building other packages which
use the "progress-tree-hp-hashmap" feature of the "%{crate}" crate.
%files -n %{name}+progress-tree-hp-hashmap-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+progress-tree-log-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+progress-tree-log-devel %{_description}
This package contains library source intended for building other packages which
use the "progress-tree-log" feature of the "%{crate}" crate.
%files -n %{name}+progress-tree-log-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+render-line-autoconfigure-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+render-line-autoconfigure-devel %{_description}
This package contains library source intended for building other packages which
use the "render-line-autoconfigure" feature of the "%{crate}" crate.
%files -n %{name}+render-line-autoconfigure-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+signal-hook-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+signal-hook-devel %{_description}
This package contains library source intended for building other packages which
use the "signal-hook" feature of the "%{crate}" crate.
%files -n %{name}+signal-hook-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+time-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+time-devel %{_description}
This package contains library source intended for building other packages which
use the "time" feature of the "%{crate}" crate.
%files -n %{name}+time-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unicode-segmentation-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unicode-segmentation-devel %{_description}
This package contains library source intended for building other packages which
use the "unicode-segmentation" feature of the "%{crate}" crate.
%files -n %{name}+unicode-segmentation-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unicode-width-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unicode-width-devel %{_description}
This package contains library source intended for building other packages which
use the "unicode-width" feature of the "%{crate}" crate.
%files -n %{name}+unicode-width-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unit-bytes-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unit-bytes-devel %{_description}
This package contains library source intended for building other packages which
use the "unit-bytes" feature of the "%{crate}" crate.
%files -n %{name}+unit-bytes-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unit-human-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unit-human-devel %{_description}
This package contains library source intended for building other packages which
use the "unit-human" feature of the "%{crate}" crate.
%files -n %{name}+unit-human-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 26.2.2-1
- Rebuilt for MSVSphere 9.3
* Mon Sep 18 2023 blinxen <h-k-81@hotmail.com> - 26.2.2-1
- Update to version 26.2.2 (rhbz#2233555)
* Sat Jul 29 2023 blinxen <h-k-81@hotmail.com> - 25.0.1-3
- Activate unit-human feature that is required by gix-features
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 25.0.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Mon Jul 17 2023 Fabio Valentini <decathorpe@gmail.com> - 25.0.1-1
- Update to version 25.0.1; Fixes RHBZ#2223182
* Thu Jul 06 2023 blinxen <h-k-81@hotmail.com> - 25.0.0-1
- Initial package (rhbz#2219471)